Zaptel-freebsd and UK CLID


#1

I’ve recently migrated from AAH to Asterisk 1.2 on FreeBSD-6-RELEASE… and it’s looking good. Here’s the thing that is bothering me now:

I have been playing with Asterisk config trying to get UK Caller ID working (yes there’s been other sites/threads on this subject I know) , but I’ve discovered something and wondered if others could shed light on it

By default, loading the BSD zaptel drivers with loadzone=us in zaptel.conf; Caller ID works; load it with loadzone=uk, Caller ID doesn’t work, HOWEVER if I modify zonedata.c line 90 (from latest SVN trunk), and give it the same ringtone pattern as US; modify back to loadzone=uk, caller ID works… I leave the other lines alone…

so changing line 90 of zonedata.c from:
{ 4, “uk”, “United Kingdom”, { 400, 200, 400, 2000 },
to:
{ 4, “uk”, “United Kingdom”, { 2000, 400 },
and leaving everything else alone, I have to put up with the US ringtone, but Caller ID works… I have also tried setting up line 90 as:
{ 4, “uk”, “United Kingdom”, { 400, 200 },
and caller ID continues to work; so it appears if you specify any more than 2 parameters to the zonedata, it breaks caller ID.

Thoughts / Speculations as to why ?

LandRocket


#2

I use a TDM400P with 1 FSO and 1 FSX module with
zaptel-1.2.4 and Asterisk 1.2.5 running under Suse 10

My phone Line is provided by BT (UK)

Receiving the CLID works directly the options required in the zapata.conf files are :

usecallerid=yes
cidsignalling=v23 ; Added for UK CLI detection
cidstart=polarity ; Added for UK CLI detection
restrictcid=no

; Select FSX signaling for the FSO module (module4 on the dev Kit)
;
context=incoming
signalling=fxs_ks
callerid=asreceived

;in the extension.conf file you add add a debug to verify that the CLID is well received.

[incoming]
exten => s,1,Verbose(Incoming call from BT line – CallerID=${CALLERID})

;dial DECT base via Z interface
exten => s,n,Dial(Zap/1,90,190,o)
;;; I still fail to forward CLID via an analog interface

;dial Dominique SIP soft phone
;exten => s,n,Dial(SIP/dominique,90,190,o)
;;; CLID is well forwarded on a SIP phone