CallerID questions and clarification

Hi ,
I know a lot of you are thinking ‘that old chestnut’ but here goes.

I am running Asterisk 1.2.13 which I successfully compiled, and I have Zaptel 1.2.11. All of my stuff is compiled from source BTW.

Now I have been trying to get UK CallerID to work, but I am a little confused. I have read from various sources that you need to patch Zaptel to get CallderID to work on a BT line. DO iahe have to patch, because I had read that the necessary work had been done to the Zaotel drivers to support UKcaller ID.

I have got an TDM-400P with one PXF in slot 4, so it apears as channel => 4 on my zaptel.conf.

Now the card itself is picking up analogue calls and my extensions are ringing OK. Now you can see below I have a debug line on my extensions.conf file to show the caller ID in my console but nothing appears.

This is my zapata.conf

; Zapata telephony interface
; Configuration file
; You need to restart Asterisk to re-configure the Zap channel
; CLI> reload
; will reload the configuration file,
; but not all configuration options are
; re-configured during a reload.
cidsignalling=v23 ; Added for UK CLI detection
cidstart=polarity ; Added for UK CLI detection

callerid=asreceived ; propagate the CID received from BT
rxgain=5 ;levels set to reduce echo
txgain=5 ;levels set to reduce echo
channel => 4

Now my extensions.conf


; If the incoming call is not answered in 30 seconds, the call will be answered by the 670581 mailbox.

exten => s,1,Verbose(Incoming call from BT line . CallerID=${CALLERID}) ; add a debug line with the received CID on asterisk console

exten=> s, 2, Dial(SIP/2001&SIP/2002&SIP/2003, 30, o)
exten=> s, 3, VoiceMail(b670581@default)
exten=> s, 4, VoiceMail(u670581@default)

; Local extension handling.
exten => 2001, 1, Dial(SIP/2001, 100, r)
exten => 2001, 2, Busy()

exten => 2002, 1, Dial(SIP/2002, 100, r)
exten => 2002, 2, Busy()

exten => 2003, 1, Dial(SIP/2003, 100, r)
exten => 2003, 2, Busy()

; If emergency numbers are dialled, it goes out onto 999 on analogue circuit.
exten=>999, 1, Dial(${ANALOGUE}/999)
exten=>911, 1, Dial(${ANALOGUE}/999)
exten=>112, 1, Dial(${ANALOGUE}/999)

; If 1471 is dialled it will go out onto Analogue circuit.
exten=>1471, 1, Dial(${ANALOGUE}/1471)
exten=>1471, 2, Congestion()

; If there is a trunk call being placed, then it will first try and call out on 888194, and then 888171.
; Last resort is to dial out on Ananlogue circuit.
exten=>_0., 1, Dial(SIP/voiptalk_line_one/${EXTEN})
exten=>_0., 2, Dial(SIP/voiptalk_line_two/${EXTEN})
exten=>_0., 3, Dial(${ANALOGUE}/${EXTEN})
exten=>_0., 4, Congestion()

; A local call will be dialled out onto analogue circuit.
exten=>_Z., 1, Dial(${ANALOGUE}/${EXTEN})
exten=>_Z., 2, Dial(SIP/voiptalk_line_one/01686${EXTEN})
exten=>_Z., 3, Dial(SIP/voiptalk_line_two/01686${EXTEN})
exten=>_Z., 4, Congestion()

; Handle rings from all other numbers.
exten=>voiptalk_line_one, 1, Dial(SIP/2001&SIP/2002&SIP/2003, 30, or)
exten=> s, 2, VoiceMail(b888194@default)
exten=> s, 3, VoiceMail(u888194@default)

;exten=>voiptalk_line_two, 1, Dial(SIP/2001&SIP/2002&SIP/2003, 10, or)
;exten=>voiptalk_line_three, 1, Dial(SIP/2001&SIP/2002&SIP/2003, 10, or)
;exten=>voiptalk_line_four, 1, Dial(SIP/2001&SIP/2002&SIP/2003, 10, or)
;exten=>voiptalk_line_five, 1, Dial(SIP/2001&SIP/2002&SIP/2003, 10, or)

; If caller dials 1571, passes through to Anserphone system.
exten=> 1571, 1, VoiceMailMain()

Any advice greatfully recieved. I have’nt gone over to Asterisk yet so that’s why the incoming voiptalk numbers are commented out.



are you loading wctdm with options “opermode=UK” ?

edit : just noticed … does it make a difference if you move the statements from [global] to [channels] ??

FWIW i got fedup with CallerID on my TDM and swapped to a Sangoma A200 … 100% everytime. YMMV

Brilliant! I get caller ID by moving the statement from [global] to [channel].

Cheers mate,


There shouldn’t even be a global section in zapata.conf…

There is according to

let /usr/src/asterisk/configs/zapata.conf/sample be your guide young master luke.

Thank you Master Obi-Wan. I shall study it between between Lectures in the Force (and Moments).