Voice mail; no sound / message

trying to configure test voicemail at the moment. my config’s look like this;
exten => 1000,1,dial(sip/1000,20)
exten => 1000,n,VoiceMail(1000@incoming)
exten => 1000,n,PlayBack(vm-goodbye)
exten => 1000,n,hangup()


1000 => 1000,1000,@gmail.com
1001 => 1001,1001,

when i dial 1000 on softphone i get a few rings and then blank air, no message is played. I have tried adding the ,u for unavailable but no difference. i have tried a couple of different configurations but all are the same; no message plays. I can leave a voice message and the system e-mails me with the message which i can playback etc so that part is working fine. i have set up extension 7000 for vm retrieval and same issue there, blank air, no pw request for login no nothing. What am i missing here? Thank-you!

That looks correct. Are you able to verify audio in your direction with something like this…

exten => 1000,1,Playback(tt-monkeys)

the playback function is… well… not. There’s no PlayBack sounds (hello-world weasel monkeys etc etc) playing back at all. the voicemail function while working as far as recording my incoming messages and e-mailing them to me has no outgoing message. They sound related to me; am i missing a plug in or something that would prevent outgoing voice etc? When i set up in coming PPTN (?) (land lines dialing in) i found that the other user could hear me although the sound quality wasn’t great apparently but i could not hear them at all. This held true on a number of different softphones and now that i think about it may also be related. Thanx!

Sounds like you have a nat problem. Read up on SIP / RTP with NAT. You will be able to see what is wrong. What does your network setup look like?

Asterisk is installed on a VPN server so not behind any home firewall or what ever.

A VPN server? So a server over a VPN? Or a VM server, as in a virtual machine?

Are you remote or local to the box? Have you confirmed the SIP settings are correct for the UTP audio stream to be bound properly?

What does an RTP debug show during the active voicemail call with no audio?

sorry… ahhhhhh… VPS not VPN… that’s another cpu and another problem i’m having elsewhere. I am remote to the server. I will try and locate the bug file and check it. Thanx!

when i log on from a test extension it tells me that it has recieved a SIP subscribe from a user without a mailbox… this is of course untrue. I’m also getting an error message on core reload regarding res_config_idap.c:1658 parse_config no directory or URL found.

They are not related to your original problem. The LDAP problems suggests a DNS configuration issue.

I think the other one is a phone configuration issue, but only affects the messaging waiting indicator.

Don’t assume that everyone knows what VPS means. Virtual machines normaly cause choppy audio, not total lack of audio. That is almost always a NAT or firewall issue.

David: Thanx for input, valid point… Virtual Private Server or Cloud Server i believe is another term. Anyway, i don’t believe it’s a phone issue as I have encountered EXACTLY the same problem from several different sources such as a Blackberry, iphone and 3 different CPU’s. I have tried two different softphones on the iphone, two on the BB and at least 3 different SP’s on each of the cpu’s (X-Lite, Jitsi and Zoipper). My Openfire instillation works flawlessly for chat and data but the SIP is an issue still; specifically the voice mail at this point as well as voice quality. Excuse my ignorance but how would i go about ruling out a NAT / Firewall issue? Would this be a built-in firewall in the server? If so are there any specific settings that need to be enabled or disabled? I use ISPmanager on the server and to be honest I’m not sure what/if that has a built in firewall etc that may need to be configured to accommodate this setup. That said I still don’t see how all other functionality surrounding the voice mail works but not the outgoing message? This combined with the total lack of any “playback” function intuitively seem to be related / could be related? They are both “sound” “playback” functions no? I am a newbie for sure so what do i know but it just seems to be to coincidental? Again thanx for the input!

Checked out the firewall on the server and all “services” are showing as opened. is there a specific port that should be referenced in the list (i’d post the image here but I don’t see a function that allows for that.)? Thanx again.

this is getting even stranger. I set up an ipkall.com number when i set this server up and it works flawlessly. When i dial the 360 number it rings answers plays monkey noises goes to unavailable message records message and e-mails it to me. extension to extension calls are still not working though (as far as playbacks go and the unavailable message.). Does this narrow down the issue at all?

All UDP ports above 1024 should be open outbound and 5060, plus the range specified for RTP in sip.conf should be open inbound.

k. I will readup on how to open these ports as it does not appear to be a menu option in firewall/ispmanager. RTP wise I do not have anything specified there in sip.config; looks like this at the moment;



etc etc per extension.

I’m sure david55 mistyped and meant to type rtp.conf.

Also try adding nat=yes to the phone definition.

For kicks also add externip=xxx.xxx.xxx.xxx/netmask to the [general] section of sip.conf.

Also read this…

svn.digium.com/svn/asterisk/bran … ctices.txt

Sorry. rtp.conf.

[quote=“root52”]I’m sure david55 mistyped and meant to type rtp.conf.

Also try adding nat=yes to the phone definition.

 Phone Definition?

For kicks also add externip=xxx.xxx.xxx.xxx/netmask to the [general] section of sip.conf.


Also read this…

svn.digium.com/svn/asterisk/bran … ctices.txt[/quote]

 lol.... ya thanx for that.  I will be changing EVERYTHING once I have it operational.  I figured this would keep everything simple for testing purposes.... that was 30 days and counting ago!

Thank-you very much for the input!

sorry to be such a newbie at this but I’m stuck again here. I can’t figure out how to add a port to the opened list in ISPmanager firewall. I have tried adding a service but that didn’t work and there simply isn’t an option in the firewall to just open specific ports? There’s virtually no info on “how-to” open a UDP port out there that pertains to ISP. Any help would be appreciated as I’m dead in the water here at this point. Thanx for your input!

k. figured out that i need to do this through Linux script in terminal… as i say NEW at this. I ran a netstat command which tells me asterisk is using 8548 but there is no mention of Asterisk using any other port (used netstat -aunp). Does this mean the other required ports are unavailable or simply not in use at this point? Thank-you again.

Asterisk will only bind to RTP ports for the duration of the session. It chooses a port from its allocated range. Sends the number of that port in the SDP message, to the other party. and listens to it whilst the call is up.