Voicemail is driving me nuts

Ok, I have spent all night trying to figure this out, and hopefully somebody has a similar experience.

I have a very basic asterisk config. Sample configs, with the only addition being by SIP phone, and my incoming voip. Last week I got everything setup, calls were working, etc.,.

I cam across a tutorial for voicemail, followed it, and it worked. When I call my phone and dont answer, it goes to voicemail, and message is stored on server.

I created an extension to retrieve the messages:

exten => 1000,1,Ringing
exten => 1000,2,Wait(2)
exten => 1000,3,VoicemailMain

And that worked. Granted, everything is still defaults, so when I dial 1000, I get the “Comedian Mail” greeting, then it prompts for mailbox and password, then I get the menu.

Now, here is how it gets weird. Today I go and setup a new second SIP phone, and proceed to set it up for voicemail. Inbound calls go to voicemail properly when nobody answers, but I cant retrieve the messages.

When I dial extension 1000, its rings for 2 seconds, then just goes silent. No greeting, no mailbox prompts, nothing.

Any ideas what could be going on? I tried tweaking the extension 1000 so it looks like:

exten => 1000,3,VoicemailMain,s6000

Where 6000 is my mailbox. But still nothing, when I dial 1000, it just goes silent. Nothing in message log.

Please help. This is driving me nuts. I even tried re-installing asterisk from scratch - no change.


Have you watched the command line in Asterisk while dialing? This might tell you alot. From the console type “asterisk -vvvvgrc” without the quotes of course. It should load up Asterisk and sit at the command line CLI> Then you can see what it is attempting to do.

Btw, to go directly to your voicemail the command is
VoiceMail(s6000) not VoicemailMain

From the cli, this is what I see:

-- Executing [1000@default:1] Ringing("SIP/6001-081d65c8", "") in new stack
-- Executing [1000@default:2] Wait("SIP/6001-081d65c8", "2") in new stack
-- Executing [1000@default:3] VoiceMailMain("SIP/6001-081d65c8", "1000@default") in new stack
-- <SIP/6001-081d65c8> Playing 'vm-login' (language 'en')

[Jan 31 06:42:49] WARNING[8513]: app_voicemail.c:6281 vm_authenticate: Couldn’t read username
Really destroying SIP dialog ‘b4c0564313527d89@’ Method: BYE

So it looks like it is working, but for some reason, I simply can’t hear anything. Now the phone does make inbound and outbound calls fine.

I wonder if it is the Answer() command?? I don’t use it, I just issue the VoiceMail() command

I’ve actually had this problem before when calling extensions. It would ring at first and then just go dead. Turned out to be my phone was bad. I needed to return it for a new one.

Also, I’ve had instances like this where ports needed to be opened on my NAT… not sure if this is an issue that you need to deal with but I thought I would put my two cents in. Good luck!