No Sound from Voicemail

Hello again.

I have managed to connect to Asterisk server together. Now extensions from one side can call the other. Using SIP. For some reason though, I am unable to hear any sound from the phones connected to the same server. I also cannot hear the voicemail prompts on the server, but do see that the voicemail is working and when entering in the login info that works too. I just don’t hear anything.

I am running these systems on an isolated LAN with no firewalls (if this information helps).

I am new to Asterisk so please let me know if there is any other information that is required.


I have still been unable to get the voicemail up. Has anyone else experienced this problem?

I have been reading that there was a problem in previous versions. It had something to do with the date (system date should be before January 25, 2006). Alot of other posts with similar problems say that the problem is related to the codecs or signalling type. Any suggestions?

So have you tried those tips? What kind of end points you use?

I had read about setting the “canreinvite=no” and checking if there is NAT as well (both changes were in the sip.conf). Neither worked.

I double and triple checked my signalling types and codecs and they all seem ok. I am using SIP and ulaw. I have even tried specifically setting the codec and still nothing.

As for the end points, are you referring to the connector to the digium card. If so, isn’t that just a telephone line?

End point is the device you use to make a call. Are you using a hard SIP phone or a soft phone running on a computer, or an ATA (analogue telephone adapter) connected to a regular phone?

The usual suspect in your case is CODEC. Have you checked that the end point also support ulaw?