Solved a problem with Noise

I wanted to post my problem so that others could save some time troubleshooting in the future. I have seen this issue on other posts, but I wanted to put a comprehensive listing of what I did and experienced.

I had built an Asterisk server with a Dual Core Pentium 3GHz processor on a basic/low-end Intel server motherboard with 2GB of RAM. I installed the Digium TE-410P and installation went smoothly. Upon completion, I noticed the following problem:

On any calls that traversed my voice PRI, there was definite and consistent noice on the inbound side of the PRI. The person on the remote side of the PRI traversed call had great quality but the host side would always hear the noise.

Numerous calls to Digium suggested looking at IRQ conflicts, however, my Intel server motherboard would not allow me to move IRQ allocations to specific PCI slots, and in fact, no matter where I moved the card, it would share IRQ with the IDE controller. I tried other Intel motherboards, all to no avail. I could not find any other brand motherboards that used the 3.3volt PCI slot at any computer stores/suppliers in a 100 mile radius of my location (San Antonio), so after much begging/cajoling with Digium, they agreed to swap out my TE-410P with the TE-405P which uses the more common 5 volt slot.

Digium’s RMA procedures are ok, but not as thorough as I would prefer. I do like the fact that Digium’s after-sale tech support is pretty comprehensive, including their willingness to “get their hands dirty” by SSH’ing into my server and running diagnostics and changing code to get their products to work.

Once I got the right board from their RMA department (they screwed up and sent me at TE410P by mistake the first time), I bought a new motherboard, reinstalled everything on a new server, and copied over the config files and everything now works great!

Bottom line, anyone that wants to install a TE410P needs to be aware of this potential issue. I cannot say that no server motherboard will allow you to move IRQ assignments, but it appears that this is the case with most if not all Intel server boards.

Hope this saves someone else the troubleshooting time!