No sound after loading module wcte11xp


#1

I’m trying to get a Digium TE110P card working but as soom
as I load the module with

modprobe wcte11xp

the sound stops working for incoming calls (SIP and IAX).
I haven’t even started to configure the card.
Running ztcfg and restarting asterisk doesn’t help. After unloading with

rmmod wcte11xp

the sound comes back.

I’m using asterisk 1.2.4, libpri 1.2.2 and zaptel 1.2.3 from gentoo which
uses the source distribution. My configuration is very basic. I have hardly
changed anything and the configuration has worked well for a long time
but the jumper on the card is T1 instead of E1. Loading the module with

modprobe wcte11xp t1e1override=15

makes it possible to configure the card for 31 channels instead of 24
but the sound is still gone. I haven’t got the PRI to work but that could
be due to other reasons.

Before I connected the PRI line I could load the module without any
problems. Unfortunately I can’t disconnect it at the moment for testing
since it’s in another location.

Anyone who has any ideas?

best regards
Robert


#2

OK,

Seems that nobody knows the reaseon for this. I would very much
appreciate if someone could tell me if a bad zaptel configuration could
make the sound disappear for all channels by just loading the module
or if this seems to be some kind of bug in Asterisk.

best regards
Robert


#3

yea, I’ve seen this. Not sure why…but sometimes you need zaptel running properly for sound to work. Interestingly enough you can probably look at your log, dial a voicemail account for example, and see proper logging indicating that the system is sending the voice file…slightly annoying, but all isn’t lost. Go through the motions of downloading and installing the Zaptel drivers usually fixes the problem


#4

I’m having the identical issue from what it sounds like. I set up my original server with Asterisk@Home 2.2 and a TDM400P. This worked fine.

Today I’ve been pounding my head all day over this issue though. As soon as I installed the TE110P all voice prompts we’re gone. I can call from phone to phone, but my PRI wasn’t up till the last five minutes of the work day so I wasn’t able to test outward connectivity. However, If I try to record a message for the digital receptionist in AMP with *77 nothing records. If I call voice mail nothing plays. The logfile at /var/log/asterisk/full says that the wave file was played, but I can’t here it. If I pull the card and rm the module it comes back.

I’m suprised that there isn’t more information about this issue on this board. Seems like it would be pretty common.

As usual, any help would be greatly appreciated.


#5

I’m having the same problem with a TE405P and the wct4xxp module.

Are any of you, by any chance, using an Intel 865GBF like I am?


#6

I had success changing the order in which the modules load. I made sure my ‘wctdm’ module loaded before the ‘wct4xxp’ with a quick edit of /etc/sysconfig/zaptel and all was right in the world again.


#7

I’m having the same problem with a TE410P and the wct4xxp module.
It’s Intel E7520 running CentOS 4.3


#8

It sounds like a timer or drivermix problem.

Can you all post your

ls -mod output ?


#9
[root@bigboy zaptel-1.2.5]# lsmod
Module                  Size  Used by
wct4xxp                59840  0 
md5                     8001  1 
ipv6                  240225  28 
autofs4                22597  0 
i2c_dev                14273  0 
i2c_core               25921  1 i2c_dev
sunrpc                142757  1 
zaptel                196740  5 wct4xxp
crc_ccitt               6081  1 zaptel
dm_mirror              28449  0 
dm_mod                 59973  1 dm_mirror
button                 10449  0 
battery                12869  0 
ac                      8773  0 
e1000                  99757  0 
floppy                 58065  0 
ext3                  118729  4 
jbd                    59481  1 ext3
adp94xx               451700  5 
sd_mod                 20545  6 
scsi_mod              116941  2 adp94xx,sd_mod
[root@bigboy zaptel-1.2.5]# cat /proc/interrupts
           CPU0       CPU1       CPU2       CPU3       
  0:      88324      97946      97876      94260    IO-APIC-edge  timer
  1:          0          2          3          4    IO-APIC-edge  i8042
  8:          1          0          0          0    IO-APIC-edge  rtc
  9:          0          0          0          0   IO-APIC-level  acpi
 12:         16          9         18         24    IO-APIC-edge  i8042
 14:          6       1428       1335          2    IO-APIC-edge  ide0
193:       1350       1091       3637       1419   IO-APIC-level  adp94xx
201:          0          0          0          0   IO-APIC-level  wct4xxp
209:       3140          7         15         11   IO-APIC-level  eth0
NMI:          0          0          0          0 
LOC:     377989     377988     377987     377986 
ERR:          0

Futhermore, zttest hangs :frowning:[/quote]


#10

You MUST have a span configured since you are loading the driver otherwise you will have no audio at all in Asterisk!


#11

Thanks for clearing it. So if I plug and configure a span into my card the problem will be gone? I’m using SIP channel, not ZAP. MusicOnHold() plays MP3 files fine, but then I try Playback() it just hangs dead silent.


#12

Correct. No Audio will work including on sip and playbacks. All you must do is configure a span. Do not even have to configure channels or plug a T1 in, just configure the span. This is what happens when you load the module with no spans configured. Configure a span or don’t load the module at all.


#13

Edge, did you used a “Siemens Gigaset” in anyway before/earlier ?

Where does this module come from
-> crc_ccitt ??

Can you unload it as well, besides (and mainly) following anglers hint ?


#14

angler, thanks a lot. I did a basic span configuration and the sound is fine now.
However, I do still have question about crc_ccitt. I don’t have Gigaset but I cannot unload it. May it has somth do to with lib_pri?

[root@bigboy etc]# lsmod
Module                  Size  Used by
...
wct4xxp                59840  0 
zaptel                196740  5 wct4xxp
crc_ccitt               6081  1 zaptel
....
[root@bigboy etc]# modinfo zaptel
filename:       /lib/modules/2.6.9-34.ELsmp/extra/zaptel.ko
author:         Mark Spencer <markster@linux-support.net>
description:    Zapata Telephony Interface
license:        GPL
version:        1.2.5 D91029A5B59A918C05FBE7B
vermagic:       2.6.9-34.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.4
[b]depends:        crc-ccitt[/b]

#15

NP. I’m not sure what crc_ccitt is actually related to. It is nothing for lib_pri. I believe it has something to do with the kernel hdlc modules.


#16

If it helps someone, crc_ccit is a module for perfoming cyclic redundancy checks.