No Response from Digium Support on $2500 Hardware

Since it is my first post here, I am saying a big “Hello” to all members of this forum.
I am recently trying to install a digium TE420 and configure it to use E1 lines(jumpers closed).
What I have done so far:

  1. Installed Ubuntu Server 8.10
  2. Followed all the official instructions for installing Asterisk and Vicidial on Ubuntu
  3. Installed all pre-requisites suceesfully
  4. Installed Asterisk
  5. Installed zaptel - latest version

Without configuring /etc/zaptel.conf everything works fine.
When I configure all 4 spans as:

and try ztconf, the server hangs and I need to unplug the plug to restart.
Also I need to remove the card, restart, change zaptel.conf back, put the card, and wait for your answer.
What am I doing wrong?

Installed Asterisk
Installed Libpri 1.4.10
Installed dahdi-linux-complete-2.2.0-rc4+2.2.0-rc2
In /etc/asterisk/chan_dahdi.conf:
internationalprefix = 00
nationalprefix = 0
localprefix = 042
channel => 1-15,17-31
signalling = pri_cpe

In /etc/system.conf :
loadzone = es
defaultzone = es
span = 1,1,0,ccs,hdb3
bchan = 1-15,17-31
dchan = 16
echocanceller = mg2,1-15,17-31

Still the system hangs on boot.

Thanks for any hint.

Dahdi genconf gave me:

Autogenerated by /usr/sbin/dahdi_genconf on Thu May 21 15:43:42 2009

If you edit this file and execute /usr/sbin/dahdi_genconf again,

your manual changes will be LOST.

Dahdi Configuration File

This file is parsed by the Dahdi Configurator, dahdi_cfg

Span 1: TE4/0/1 “T4XXP (PCI) Card 0 Span 1” (MASTER)


termtype: te


Span 2: TE4/0/2 “T4XXP (PCI) Card 0 Span 2”


termtype: te


Span 3: TE4/0/3 “T4XXP (PCI) Card 0 Span 3”


termtype: te


Span 4: TE4/0/4 “T4XXP (PCI) Card 0 Span 4”


termtype: te


Global data

loadzone = us
defaultzone = us

Still the sysem is blocked when I run dahdi_cfg

Doesn’t Digium provide free support for initial setup of their cards on Asterisk? I would contact them.

One thing that i noticed is that you installed zaptel after installing Asterisk. I if i remember right zaptel needed to be installed before Asterisk.

Here are part of the install instructions from They also have great video tutorials for setting up Asterisk.

Thanks for the answer.
Just sorted wrong here in the description.
I have installed first libpri then zaptel(then dahdi) then Asterisk.
I have already opened a ticket in the support page of Digium.
And thanks for the link with tutorials.

Normally, how long does it take to digium to respond to a support case?
I do not need the installation for the next year.

I bought a $2500 device and no one cares.
I opened a case at Digium on 21st of May, and still got no answer.
Is this the normal way Digium does things?

Yikes that does not instill a lot of confidence in me. A month or so ago i had planned to purchase a Digium card for a new facility, but we decided against it since we had not had experience working with their support team. Sounds like it was a good idea to steer clear with support like this…

They must have a number you could call, right? You are bound to get to someone with authority if you keep calling and bugging them. I would be furious if i bought that card for the new facility and couldnt get support.

I am interested to know how this turns out and if they make things right. It will definitely help me for future purchases.

I am very new to this, and, not wanting to be very much in trouble, I decided to purchase Digium Card TE420, being one of the best cards from Digium. I thought that the compatibility between Digium cards and Asterisk shouldn’t be a problem. I followed exactly the instructions for installing it in Ubuntu 8.10 server, and now I am left with no way to go.
The only answer I got from Digium was:
You have to pay for support, so you can get answers(another $1000).
What if the card if faulty, and they say that I need to turn it back, who pays for the support?
What if their support team is as lazy as it seems?(No answer since Thursday morning, May 21st).

That is very unfortunate. Obviously I cant trust Digium to provide adequate support for their hardware as promised.

Sorry that you had to learn that lesson for me. Keep us posted. I would rename your post to ‘No Response from Digium Support on $2500 Hardware’. Might get a bit more attention.

Digium replied:

DAHDI 2.2.0 is still in its release candidate phase. If you downgrade to the latest stable release, currently dahdi (linux+tools), do you get the same behavior when running dahdi_cfg?

I changed drivers to the version mentioned, and still I get the same behavior.
The result was sent to digium support through an email.
Then, after 10 hrs with no answer, I sent another email:
Should I continue waiting?
Then I got the answer(many hrs later):
I cannot comment on when 2.2.0 will make its final release. I’ll ask again: if you downgrade to the latest stable, (linux+tools), do you get the same behavior?
Now, I re-sent the same email to support.

Given the way we are communicating(email), time difference between Albania and USA(although I’m working late 10PM), and the quality of service, I think I might be able to install by December.

So, an advice to all: Digium after sales support sucks!
Lucky me, I am still in time to return the product back.


You need to look at your log files to see whats happening, As to digium support if your emails to them are as full as your post here you just arnt giving enough information.

you need to say what the server is, and also explain fully whats happening.

IE does the server hang straight away or after a while.


Thanks for the answer and clarifications.
First, as I mentioned, I opened my case on Thursday 21st and got replied on Tuesday 26th.
I would be very pleased to answer to any specific question they need to clarify the matter, and of course, I need to hurry up with installation. If I get one email per day saying: change the driver version, or see what color server is, then I think I’m going nowhere.
FYI I have tried two servers: one HP and the other NEC.
Tried Ubuntu, CentOS and an earlier version of AsteriskNOW (I do not remember the Linux brand now).
I have tried Zaptel drivers and then went to DAHDI.
Still I get the same behavior(with all configs). Server just hangs immediately after i execute DAHDI_cfg.

Have you verified that the card is on its own IRQ in the bios? You should also disable any hardware you are not using. IRQ conflicts have been know to cause issues that either lead to voice quality problems or server hangs.

I suspected (or better the error given has something to do with IRQ) that this might be a problem.
I tried to disable IRQ errors from BIOS(as suggested in some forums), but still got the same problem.
Can you, please help me identify the problem with IRQ?
How do I set IRQ for card?
What to check?

Today’s email:
What hw revision is your card?

First I would try the DAHDI driver (and 2.1 tools as well). Re-rerun the dahdi genconf using this version just to be sure.

IRQ’s are generally set in the BIOS, usually you can disable anything not needed (CD-ROM, USB ports, mouse ports etc). From there you should be able to change IRQ’s so the slot your card is in is not sharing an IRQ with any other hardware. You may have to change the slot your card is in to be able to do that. At worst case if you cant get any way of not sharing an IRQ its better to share it with something that has very light use (i.e. a USB port that has a keyboard or mouse that is only used everyonce and a while) definately not something like the disks or network card. Sorry I cant be more specific - every BIOS is a little different.

What hardware is this? If its not a major brand server what motherboard and other hardware are in the server? There may be some incompatibilities as well.

I have already tried the DAHDI version you mentioned and still get the same result.
I have two servers: HP and NEC.
In NEC I couldn’t find any place in BIOS to work with IRQ.
I can not try in HP now as I managed to arrange a contract with Telecom for SIP. I wouldn’t need the card now, so I will send it back.
I suggest to all the members of this forum to really consider purchasing Digium products given the quality of the after sales support.

Thanks a lot for trying to help.


I have to say I have never had any issues with Digiums support.

It seems from your problems and trying multiple platforms you may well have had some sort of incompatibility.

But as in this post other that continually rubbishing the support you posted no information that may have helped in the installation. for example you never actually state the model and never post the output of lsmod or lspci. Also it would be expected that initial support would be from the local supplier of the card, If they cant or wont then your issue is with them, They are the ones who will have made a nice profit.

It is expected that the hardware is installed and purchased by users who are competent in the installation of the OS and hardware.

I will second ianplain, I have contacted Digium several times for card support and they have always resolved the issue.

The fact that you couldnt change IRQ’s on the NEC system tells me the NEC is a cheap home user class machine and would not be surpirised if there was a hardware conflict. Based on the fact you bought a 4 E1 port card you must be planning on running 120+ simultaneous calls so you really should be running on server class hardware.