TE120P problems!

Well im a relative beginner at Asterisk … Until now i have only manged to configure asterisk and make an AGI script work for softclients like X-Lite.

I want to further this by being able to connect through any cell phone etc. FOr this since I have a ISDN phone line I got a TE120P card.

I have installed it and tried just abt evryhting i read evrywhere ie.

modprobe wcte12xp
ztcfg -vvv
dmesg (for checking)

lspci gives me :
0000:03:0c.0 Ethernet Controller:Digium,Inc.:Unknown device 0120(rev 11)

But i continuosly get the output of zttool and “zap show status” as RED alarm.(and the IRQ colum shows 14… bpviol and CRC4 =0)

My question/s :
1.)What could be the interface problem …How do i get the green signal?
(What I have thought from other posts in the forum :Cable problem…I dont know if my cable is the RJ45 type…is there any non destructive way to check? I am using the same cable that i connected the ISDN phone with from the wall socket)

2.) Im not sure as to how i configure the extensions.conf for dialing in from any landline number…Jus could someone please clarify how it works…As in if i just call the telephone number that the line corresponds to from any number asterisk should respond??

And i also changed the zaptel.sysconfig file to have the line :
MODULES=’$MODULES=wcte12xp’ as i read in some other forum

group =1



Please contact Digium support via:

The cable you’re using for your ISDN phone is not wired the same as a T1/E1 crossover cable, so you’re going to stay in red alarm until your cabling is correct. The pinout should be such that Pin 1 on side A is mapped to Pin 4 on side B and Pin 2 on side A is mapped to Pin 5 on side B.

Hey thanks…

I was guessing it could have been a cord problem. I will soon get the cord anf try out with that.

Just as trial I tried cutting a normal LAN cord and connecting it in :
1.)Loopback mode 2.)the crossover mode that you mentioned 1->4 and 2->5

Correct if im wrong, The loopback mode worked gr8 and showed the green signal on zttool and the PCI device itself. But for some reason when i snnected 1 <–> 4 and 2 <–> 5 I still did not get the green signal? Do you figure this is just some loose connection on my side or is there a reason for it to not work?


Please contact Digium support via:

If the loopback has worked successfully; but plugging into your T1/E1 drop via a straight-through or T1/E1 cross-over cable does not bring the line up, then something is amiss with the drop or the far end.

Again, please contact Digium support via:

I will not be able to provide you with further assistance.

Hey thanks again…

I have sent mail to the Digium guys. Hope they help me out here. Seems pretty weird. Cant understand why it shouldnt work now with the correct cable as well…

Still having the same problem…And still the loopback works which is making it even more of a weird proposition!

Thanks though!

Has the Telco enabled the circuit? They wont normally till you ask them. Also are you 100% sure you hav ethe signalling correct.


Yes am pretty sure about the pri_cpe and 5ess switching types…infact yea 100% …

By the telco enabling it do u mean for asterisk purposes i have to call up the telco and tell them to enable the line? Since the phone I had connected to it earlier was and is still working when connected to the line wudnt that mean the line is enabled? or does it require a special enabling???


I have just read your orignal post.

Could you explain further. what type of ISDN phone? are you sure you have a PRI circuit and not a BRI circuit ?

If you have BRI then you have the wrong card and will never get it to work.



Its a ISDN 7506 type phone! And even before I paste this below link I think you are right!! Really very shoddy of me to make a mistake like that!!

support.avaya.com/edoc/docs/term … m67us1.pdf

I think it is a BRI connection…As far as this and some other documents that I just went through for the telephone and the line…

Are you in agreement to that?

Ahh…and heres confirmation of the BRI line…

The phone i used was connected to the socket through an NT1 device…


this one to be precise…and the first line of this webpage clearly says this device is required only for BRI ISDN connection…

Well pretty weird actually didnt think of this cos all webpages i had gone through earlier said USA has only PRI and BRI is onyl in Europe!!

ANyways thanks a million!!!

Ah you should NEVER believe all you read on the web, ISDN2 or BRI is avalible in most countries. Its just that its popular in europe.

Oh well you now need to get ISDN2 card or gateway


Ohh and just so that i dont mess up again…


This card should be the correct one right?? I guess from all i searched B410P is the only BRI ISDN card by Digium…And this one is a lot more expensive so i better be sure before i order!!

Thanks once again though!! Cant tell you how relieved I am though still a way away to configuring it all and making stuff work…

You do have some other choices telephonyware.com/telephonyware/tw00462.html
or most cheap cologne hfc chipset bri cards and bristuff will also work.

Or look at a something like a vegastream europa ISDN2 to sip gateway.


Thanks once again!!!