No audio


#1

I have a mostly untouched config of A@H, other than modifying the root password, zaptel.conf and zapata.conf (to work with a TE411P card). Trying to play any audio results in silence. This is for voicemail, and “playback” commands, MoH, etc.

Calls from phone to phone work fine, but using *43, or *98, or any of the other built in extensions just results in silence on the phone that has called.
Watching from the CLI, I see the call being picked up as expected, and the Playback application executing. E.G.:

– Goto (macro-vm,s-CHANUNAVAIL,1)
– Executing VoiceMail(“SIP/2002-84cc”, “u2001@default”:wink: in new stack
– Playing ‘vm-theperson’ (language ‘en’)

After reading a topic below, I attempted unloading the wcusb modules, but that did not resolve the issue.
A@H is running on a Dell PE1750. No sound device is installed, but I didn’t think this was necessary for playback, only if you wanted to do dialing from console or intercom applications.

Any ideas what may be behind this? Help would be GREATLY appreciated.


#2

Check to make sure that Festival installed correctly. That is what it sounds like. You need festival for the txt to speech to work.

You might try a simple context like -

exten => 9,1,Dial(SIP/9)
exten => 9,2,Playback(beep)

Set for auto answer on the phone. When the phone answers a beep is played.


#3

I don’t really think it’s a festival issue, as it’s attempting to play gsm files and is not producing any audio as a result, rather than failing on TTS.

I actually reloaded the box - from A@H to Rapid, and am still seeing the same issue, so I am pretty sure it’s not a config issue.

Is anyone else running * on a Dell PE 1750 and successfully playing files?


#4

I did test as per your suggestion, and still get no audio.


#5

go into your cli and do a “show modules like gsm” - what comes up?


#6

It doesn’t show any modules, however “show modules” does list the three gsm modules: codec_gsm, format_gsm, and format_wav_gsm.


#7

I’m really stumped on this one, can anyone offer any input?


#8

You haven’t said anything about your setup. What sort of phone are you using, for a start? Soft or hard? Which particular phone?

By the looks of it, you’re using a SIP phone of some sort. When you say calls work between two phones, what sort of phones are they and what sort of configuration? For example, you could be using two SIP phones with canreinvite=yes and they’re doing audio directly from one to the other without asterisk’s involvement. In which case, the fact that they’re working wouldn’t tell us anything about asterisk’s audio problem.

What’s the network topography? The phone that it’s not working with wouldn’t happen to be a SIP phone that’s got a NAT firewall between the asterisk box and it, would it? If it’s SIP, is there anything blocking the RTP ports that asterisk and the phone are using?

Etc…


#9

This happens with both soft and hard phones, SIP and IAX2.
As I mentioned, the phone to phone calls work fine, it’s only on audio playback where I get no sound.
The * console shows that a .gsm file is being played, but there is only silence.

The * server and soft/hard phones are all on the same network segment.


#10

Hi

I bought the same card. Would you mind let me know which version of asterisk you are using?

(1)check out the cvs head or
(2)Asterisk Version 1.0.9
Zaptel Version 1.0.9.2
Libpri Version 1.0.9
Addons Version 1.0.9
Sounds Version 1.0.9

Thanks a lot

yang


#11

1.0.9 for everything.


#12

I have the same problem

I’m using Asterisk@home 1.5
My Computer is a Dell Optiplex GX-520 (Mini Tower)

The problem is the following:
My Asterisk work’s fine without the CARD.
As soon as I plug in the card,(with out any configuration, just plugin in the card into the pci slot.) The Playback cmd, Background cmd and MOH stops working. I get a silence instead. If I unplug the card, everything works fine again.

I’m able to talk with the sip phones in both cases with out problems.

What could be making the sound go off from Asterisk ???


#13

:smile:


#14

I am having this same issue. I have Tried the latest version of A@H (2.2) as of today (12/15/05). Installed it (pressed enter and let it run; how sweet) Created 2 extensions and set voicemail up on them through the AMP interface. Set up one of the phones on a hard Zyxel 2000W_V2 and the other up on X-lite. I dial from one phone to the other (either way same result) and as I watch the asterisk console (asterisk -r) it says it is playing the the ‘vm-theperson’ (language ‘en’) but nothing is heard on the phone… Here is the asterisk event log:

-- Registered SIP '100' at 80.129.62.111 port 64903 expires 1800
-- Executing Macro("SIP/100-0b26", "exten-vm|400|400") in new stack
-- Executing Macro("SIP/100-0b26", "user-callerid") in new stack
-- Executing DBget("SIP/100-0b26", "AMPUSER=DEVICE/100/user") in new stack
-- DBget: varname=AMPUSER, family=DEVICE, key=100/user
-- DBget: set variable AMPUSER to 100
-- Executing DBget("SIP/100-0b26", "AMPUSERCIDNAME=AMPUSER/100/cidname") in new stack
-- DBget: varname=AMPUSERCIDNAME, family=AMPUSER, key=100/cidname
-- DBget: set variable AMPUSERCIDNAME to Victor
-- Executing GotoIf("SIP/100-0b26", "0?5") in new stack
-- Executing SetCallerID("SIP/100-0b26", ""Victor" <100>") in new stack
-- Executing NoOp("SIP/100-0b26", "Using CallerID "Victor" <100>") in new stack
-- Executing SetVar("SIP/100-0b26", "FROMCONTEXT=exten-vm") in new stack
-- Executing Macro("SIP/100-0b26", "record-enable|400|IN") in new stack
-- Executing GotoIf("SIP/100-0b26", "0 > 0?2:4") in new stack
-- Goto (macro-record-enable,s,4)
-- Executing AGI("SIP/100-0b26", "recordingcheck|20051215-132324|1134671004.104") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck

recordingcheck|20051215-132324|1134671004.104: Inbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing NoOp(“SIP/100-0b26”, “No recording needed”) in new stack
– Executing Macro(“SIP/100-0b26”, “dial|15|tr|400”) in new stack
– Executing GotoIf(“SIP/100-0b26”, “0?4:2”) in new stack
– Goto (macro-dial,s,2)
– Executing GotoIf(“SIP/100-0b26”, “0?5:4”) in new stack
– Goto (macro-dial,s,4)
– Executing AGI(“SIP/100-0b26”, “dialparties.agi”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
– dialparties.agi: priority = 4
– dialparties.agi: callingani2 = 0
– dialparties.agi: accountcode =
– dialparties.agi: channel = SIP/100-0b26
– dialparties.agi: callerid = 100
– dialparties.agi: context = macro-dial
– dialparties.agi: callington = 0
– dialparties.agi: dnid = 400
– dialparties.agi: request = dialparties.agi
– dialparties.agi: calleridname = Victor
– dialparties.agi: extension = s
– dialparties.agi: language = en
– dialparties.agi: uniqueid = 1134671004.104
– dialparties.agi: callingpres = 0
– dialparties.agi: type = SIP
– dialparties.agi: rdnis = unknown
– dialparties.agi: callingtns = 0
– dialparties.agi: enhanced = 0.0
dialparties.agi: Caller ID name and number are '100’
dialparties.agi: Methodology of ring is ‘none’
– dialparties.agi: Added extension 400 to extension map
– dialparties.agi: Extension 400 cf is disabled
– dialparties.agi: Extension 400 do not disturb is disabled
– dialparties.agi: Checking CW and CFB status for extension 400
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
– dialparties.agi: Correct AMPMGRUSER and AMPMGRPASS
== Manager ‘admin’ logged off from 127.0.0.1
dialparties.agi: Extension 400 is available…skipping checks
– dialparties.agi: DbSet CALLTRACE/400 to 100
– AGI Script dialparties.agi completed, returning 0
– Executing Dial(“SIP/100-0b26”, “SIP/400|15|tr”) in new stack
– Called 400
– SIP/400-07ef is ringing
– Nobody picked up in 15000 ms
– Executing GotoIf(“SIP/100-0b26”, “0?s-NOANSWER|1”) in new stack
– Executing GotoIf(“SIP/100-0b26”, “0?s-NOANSWER|1”) in new stack
– Executing NoOp(“SIP/100-0b26”, “Sending to Voicemail box 400”) in new stack
– Executing Macro(“SIP/100-0b26”, “vm|400|NOANSWER”) in new stack
– Executing Macro(“SIP/100-0b26”, “user-callerid”) in new stack
– Executing DBget(“SIP/100-0b26”, “AMPUSER=DEVICE/100/user”) in new stack
– DBget: varname=AMPUSER, family=DEVICE, key=100/user
– DBget: set variable AMPUSER to 100
– Executing DBget(“SIP/100-0b26”, “AMPUSERCIDNAME=AMPUSER/100/cidname”) in new stack
– DBget: varname=AMPUSERCIDNAME, family=AMPUSER, key=100/cidname
– DBget: set variable AMPUSERCIDNAME to Victor
– Executing GotoIf(“SIP/100-0b26”, “0?5”) in new stack
– Executing SetCallerID(“SIP/100-0b26”, ““Victor” <100>”) in new stack
– Executing NoOp(“SIP/100-0b26”, “Using CallerID “Victor” <100>”) in new stack
– Executing Goto(“SIP/100-0b26”, “s-NOANSWER|1”) in new stack
– Goto (macro-vm,s-NOANSWER,1)
– Executing VoiceMail(“SIP/100-0b26”, “u400”) in new stack
– Playing ‘vm-theperson’ (language ‘en’)

Any help with this would be greatly appreciated. Whatever advice is more than welcomed… :smile: Thanks guys


#15

[quote=“elmono_acosta”]I have the same problem

I’m using Asterisk@home 1.5
My Computer is a Dell Optiplex GX-520 (Mini Tower)

The problem is the following:
My Asterisk work’s fine without the CARD.
As soon as I plug in the card,(with out any configuration, just plugin in the card into the pci slot.) The Playback cmd, Background cmd and MOH stops working. I get a silence instead. If I unplug the card, everything works fine again.

I’m able to talk with the sip phones in both cases with out problems.

What could be making the sound go off from Asterisk ???[/quote]

Hello, i’m experiencing the same problem as you post there, i’d like to know if you came up with any solution to it.

Thanks in advance

Marcos Medvescig