Silence instead of sound file when filename in dialplan

Hi,
In a super-simple dialplan where the only thing to do is playback a sound file all I get is silence:
[first_context]
exten => s, 1, Playback (thank-you)
The file “thank-you” is a GSM file (thank-you.gsm) and is in /etc/asterisk. Instead of hearing the sound file, all I get is silence from asterisk when it picks up.
I have a whole bunch of GSM files in asterisk-sounds directory. How to get asterisk to play any of those files?

sounds like a codec issue. what codec is the UA using ?

:smiley: :blush: How to inspect which codec am I using?

let’s see the sip.conf entry for the calling extension.

another possibility would be incorrect permissions on the sound files.

At first glance, I would have to ask if /etc/asterisk is the right directory? A default install puts the files in /var/lib/asterisk/sounds.

Just a thought…

well spotted !!

I didn’t edit anything in sip.conf as this is a connection with the POTS line (single telephone line going into X100P with asterisk-1.2.9.1 waiting for calls on the other side).
Asterisk is executed as root and all the changes to any conf file are as root, as far as permissions go.
The PC I am working on is a dedicated CentOS 4.2 Asterisk server with no network connection, just POTS to X100P.
The sip.conf file that you asked for would take considerable amount of space in one message. But if it is of importance for solving the problem at hand, I will gladly send it to you as attachment.
Thank you for your patience

i give up. it’s like pulling teeth.

[quote=“lacymoore”]At first glance, I would have to ask if /etc/asterisk is the right directory? A default install puts the files in /var/lib/asterisk/sounds.

Just a thought…[/quote]
I have the same GSM bunch in /var/lib/asterisk/sounds…

… or do I have to install some special player?

no. post the relevant parts from zapata.conf, from extensions.conf and the section of a fully featured logfile for an attempted call.

OK, here we go:

zapata.conf:

context=first_context
switchtype=national
signalling=fxs_ks
rxwink=300
usecallerid=yes
hidecallerid=yes
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
rxgain=0.0
txgain=0.0
group=1
callgroup=1
pickupgroup=1
immediate=no
callerid="*X100P POTS"<(123)456-7890>
channel =>1

extensions.conf, the context:
[first_context]
exten => s, 1, Wait(1)
exten => s, 2, Playback(florida)

Feedback from Asterisk CLI:
NOTICE[11122]:chan_zap.c:6061 ss_thread: Got event 18 (Ring Begin)…

and that is it, as far as CLI feedback…

try replacing s,2 and adding:

exten => s,2,Answer()
exten => s,3,Playback(florida)

Looks as though Asterisk never answers the call.

Even with that change in dialplan (and restarting asterisk), there’s still silence on the other side without playback. And the same CLI output:
“Got event 18 (RingBegin)” without anything else about execution of anything from the dialplan…

    • File thank-you does not exist in any format (perhaps)
    • No such file or directory
    • No GSM codec supported (try adding allow=gsm) on sip.conf below [general] context.

Did the change in sip.conf and to no avail. I also added some rules in udev regarding zaptel (soemthing I ommited when installing asterisk) and changed the [first_context] dialplan to see if only the playback is the problem:
[first_context]
exten => s, 1, Answer()
exten => s, 2, Busy()
exten => s, 3, Wait (1)
exten => s, 4, Hangup()

and all I hear is noise, no tones, nothing… CLI feedback records only Ring Event and doesn’t show progress of any execution of the dialplan…
I reallly wonder what is the catch, is there an “ahaaa” part that I missed?

Can soundcard be a factor in playback of asterisk .gsm files (tried to play MP3 files on the asterisk box via RealPLayer 10 with poor results)?

get a network card in the thing and let someone take a look.

Out of curiosity, how are you calling into the system?

Via cellphone… tried also to call in from phones other than my cell phone but results are the same. Have also tried with playback of my own recorded files transfered to gsm format (via sox application) and changed soound card as well, again, result is the same… noise while supposed playback and a click for hangup…