Installing asterisk from source over the top of a precompiled install

Hi guys, i am setting up a test asterisk 13 system for using the ARI for software development.

I used a prebuilt system (apt-get install asterisk13) with freepbx which worked well but i found a bug which i needed to patch with a .diff which you need a source install to apply. Only version 14 of asterisk has the bug patched so i removed 13 and installed 14 from source. But that caused me to lose all my settings, and even if i copied settings across the best i could do is get freepbx to connect to asterisk but things were broken in freepbx. Eg if i tried to look at my extensions a heap of php exception would get thrown.

What i want to do is install the same version of asterisk i currently have from source overwriting the current pre compiled apt-get install so that i can keep all my settings and not make freepbx get really cranky.

Can anyone help?


The FreePBX part of this question needs to be asked on

The risk of doing this with Asterisk is that you may have not built the same subset of modules. Hopefully, with modern Asterisks, the left over modules will refuse to load, but if they do load, they could cause crashes. It is best to clear out the modules directory.

I’m not sure if FreePBX has been tested yet with Asterisk 14. There shouldn’t be significant incompatibilities between 13 and 14 - I’d be curious as to which part isn’t working.

Matthew Fredrickson

The issue is with the rest api in which if you make a call to a stasus application in a dial plan and try to ‘continue’ back to the dial plan after stasus is complete, the channel hangs up instead of continuing.

I found this on 13, but i believe its been fixed on 14. Simply upgrading to 14 on a freepbx system broke it. So i wanted to stick with 13 and patch it myself from source. Sorry for slow reply, i had to take a couple of weeks off work due to illness.

Clearing out the modules directory seemed to do the trick david551. I then removed the precompiled 13 install, downloaded the source for the same version, patched the bug using a .diff file and did a full compile and install. After all that though the bug that was tearing my hair out is still there!!? But that’s another subject…