Gui does not write in config files sip.conf or extension.con

Hi,

i am new with asterisk but quite a bit expirienced with Linux. After i runned AsteriskNow trough VMWare I expirienced the following problems, as i do not think it is a Bug i will lock forward maybe somebody can explain me what I am doing wrong:

After boot up i setup some users and updated the configuration. I did even a sip reload and a extension reload trough the CLI.
But still I was not able to register I got always a message with indicating the requester is not setup in the ACL (Error 404). I 've rebooted but still no change. After some investigation I ve found some information that the user and extension are not written to the sip.conf and extemsion,conf (by the way no change in the two named config files nothing setup in there) they shoud be written in the sip_additional.conf and extension_additional.conf. But these files are not there in the etc/asterisks folder.

After i setup the accounts manually through SSH in the Sip and extension configuration files it worked and i was able to register,

I would appreciate if somebody could tell me what I am doing wrong or if it is normal to change this two files manually with AsteriksNow GUI.

Thank you in advance

Does nobody has the same symptoms or the same issue?

I really would appreciate if somebody could give feedback.

I am not clear on exactly what the problem is. It sounds like you are able to update the sip.conf and extensions.conf files using a text editor, reload Asterisk and your softphone can register. If you use the GUI then the files are not updated and the endpoints cannot register.

If my description of the problem is correct then I have never seen this problem on a fresh installation. I have successfully screwed with the persmissions inside /etc/asterisk which has either prevented FreePBX from updating the conf files or I have screwed with Freepbx/httpd/apache/php and broken the ability for the gui to operate properly.

The configuration file hierarchy in AsteriskNow is a bit daunting. I depend heavily on ‘grep’ to find and update the correct conf files. (This is not a gripe. Their implementation of FreePBX is ingenious. How many other applications allow you to edit this many options via a GUI while allowing you to edit the same options via a text file and everything still works 99.999% of the time?)

The include statements inside the conf files do not guarantee the corresponding file exists.

My suggestion would be to confirm the permissions are set correctly. Try…

or

Then try making some changes and confirm the appropriate conf files are updated. Grep all the files in the asterisk folder if you need too.

Hope this helps!