Asterisk & GUI on svn problems

I installed asterisk and gui compiling from svn.
The big problem I have, is that adding sip trunk, it does not keep registered.
It registers only after first installation or after adding new sip trunks, and after some time expires.
The same settings in users.conf work for, and the peer keep registered.
Enabling sip debug, no sip registration request is done, even after a sip reload command.
If I change a file (sip.conf or users.conf) adding or removing a space in them, and the give sip reload command, I get the following on the console:

*CLI> Reloading SIP *CLI> == Parsing '/etc/asterisk/users.conf': *CLI> == Found *CLI> == Parsing '/etc/asterisk/sip.conf': == Found *CLI> > doing dnsmgr_lookup for '' *CLI> > ast_get_srv: SRV lookup for '' mapped to host, port 5060 == Parsing '/etc/asterisk/sip_notify.conf': == Found
and nothing else.

here is sip show registry:

Host dnsmgr Username Refresh State Reg.Time N AAAAAXXXYYY 120 Unregistered 1 SIP registrations.

I cannot use because the gui on svn is not working on it. The gui freezes with a windows with this message:
Checking write permission for gui folder, and stops there.

Any help will be appreciated.

why are you using 1.6.x? It is not meant to be used in a production environment (afaik) When I tried the gui it worked very well with 1.4.x