Can not edit .conf files

I tried to add custom VOIP provider from the GUI but after I selected custom voip the next screen opened asking for comment and host name etc… but when I tried to enter something the form did not allow me to enter anything.

Then I tried to edit user.conf files manually but then I found they were read only file and I was not allowed to edit them. I logged on as root and changed the file permissions but still I could not edit any of the file like users.conf sip.conf or any other .conf file in /etc/asterisk directory.

I was using admin account. Can some body help?

What GUI are you using ? What happens when you do ls -l ?

Hi Dovid,

This is the file I downloaded.
Install for x86, 32-bit processors such as Intel P4 and AMD Athlon XP
AsteriskNow Beta 4 (32 bit)

After installing I used Firefox browser to open the GUI page. How can I tell what GUI or GUI version this is?

When I do ls -l from /home/admin I don’t have any files. But doing this from /etc/asterisk I get all the conf files.

When I try to add a service provider I click on custom voip. Then I can add a comment chose the protocol check on register and nothing else.
I can not enter Host, Username or Password. I can not even enter the cursor into those boxes.

It would be greate if you can help.


I just found out you need to use sudo to edit conf files. I can edit .conf files now.