CallerId with Analogue PSTN


#1

CallerId is configured on my analogue phone line and is displayed okay when my phone is connected to the line however when Asterisk (1.0.5) is connected to the line then I get no CallerId.

Has anyone got CallerId to work with an analogue phone line in Germany (provider T-Com)?

What do I have to do to configure CallerId on inbound calls and where?

The only place I found was in zapata.conf and I did not have any joy in getting the settings there to work, but then again I did not know what to configure for Germany.

; ; Whether or not to use caller ID ; usecallerid=yes ; ; Type of caller ID signalling in use ; bell = bell202 as used in US, v23 = v23 as used in the UK, dtmf = DTMF as used in Denmark, Sweden and Nethe rlands ; ;cidsignalling=bell ; ; What signals the start of caller ID ; ring = a ring signals the start, polarity = polarity reversal signals the start ; ;cidstart=ring ;

thanks in advance for any help.


#2

You’re in the right place. v1.0.5 of Asterisk requires configuration of two variables: cidsignalling and cidstart. The supported values are:
cidsignalling: bell, dtmf, or v23
cidstart: ring, polarity

Bell/ring is the appropriate combination in the US. There’s a great CID FAQ here: ainslie.org.uk/callerid/cli_faq.htm

Unfortunately, it doesn’t shed much light on Germany. If you’ve tried all the possible combinations of the above, you’re probably out of luck. :frowning:

Good luck!

-jbn


#3

Hi,

I tried all the combinations from the following

I even tried using two different extension scripts because I was not sure if I had to answer the inbound call or not

[inbound-analog]
exten => s,1,Answer
exten => s,2,Wait(1)
exten => s,3,NoOp(${CALLERID})
exten => s,4,Hangup
[inbound-analog]
exten => s,1,Wait(2)
exten => s,2,NoOp(${CALLERID})
exten => s,3,Hangup

and I got exactly the same result for all 12 calls
[ul]
Apr 12 20:38:48 NOTICE[1657]: callerid.c:306 callerid_feed: Caller*ID failed checksum
Apr 12 20:38:49 NOTICE[1657]: chan_zap.c:5368 ss_thread: Got event 2 (Ring/Answered)…
Apr 12 20:38:53 WARNING[1657]: chan_zap.c:5439 ss_thread: CallerID returned with error on channel ‘Zap/1-1’
[/ul]