CallerID sent before first ring


#1

Dear all,

  I have an Asterisk(1.2.5) service with a TDM400 and 3 FXO modules installed.  Everything works just fine, except the callerid from PSTN.  After asking the local telecom, I found that the CallerID is sent before the first ring. The current CIDSIGNALLING supportted are DTMF and FSK/ETSI.

  Are there any ways to fixing up this mismatch ? If you have any information , plz let me know. Thanks for your kindly help !!!

#2

are you in the uk by any chance ? you could try usecallerid=yes ukcallerid=yes callerid=asreceived cidsignalling=v23 cidstart=polarity as a starting point.

you could also set immediate=yes so that asterisk doesn’t bother waiting for the US style CID. all changes are to /etc/asterisk/zapata.conf


#3

Hi,

With the setting you suggested, I still cannot make the CallerID from PSTN work. I think even with immediate=yes, the system still listen the callerid information between first and second ring.


#4
  1. where are you ?
  2. does your asterisk setup reflect your locale ?
  3. post your zapata.conf file here.

#5

Hi baconbuttie,

I am in Taiwan. I have set the indication.conf , wctdm opermode, and zaptel.conf to fit taiwan. And then try your suggestion.

Thanks for your help !!

Best regards,


#6

[quote=“jarrow”]I am in Taiwan. I have set the indication.conf , wctdm opermode, and zaptel.conf to fit taiwan. And then try your suggestion.
[/quote]well let me get out my big book of asterisk configurations and consult my magic ball to see what your config contains !!