Asterisk + Digium B410p problems

Hey everyone, I’m new here (but I’ve been scrawling Asterisk/Digium forums all week)

I know certain aspects of this problem may not be supported here and if I receive no answers because of that - then I totally understand and respect that.

Previous to last weekend (1st Sept 2012) we had a running PBX server, using Asterisk 1.6, FreePBX, a Digium OpenVox b200p card, running through 2x UK BT ISDN lines. I tried doing an scheduled upgrade on FreePBX - it crashed half way through and messed up the whole system.

After about 6 hours of attempting various fixes I couldn’t get anything to work so I decided to format the drive and install the FreePBX distro (latest Stable-1.815.210.58, Release Date-08/14/12) which obviously includes all the latest DAHDI, LibPri, and Asterisk versions.
The only difference being I opted to use a Digium B410p card (for better echo cancellation mainly) after getting set up, everything was configured correctly (as far as I could see) yet inbound/outbound calls would not work (outbound responded with various messages like ‘The number is not answering’ and ‘All circuits are busy now’, incoming- nothing at all on the CLi)

So I tried a fresh install (again with FreePBX distro) with the openVox b200p card - same again, tried a basic CentOS, manually compiling all modules, tried Elastix (on both cards) - to no avail.

To allow business to continue I had our inbound calls diverted to an VoIP provider and run that through SIP, I moved our IDSN lines to a new PBX ‘development’ server so I could focus on getting outbound working - then once I’ve achieved that, I’ll make the necessary fixes and restore the live PBX server to a working condition (and remove the diversion)

Just wondering if anyone on here could point me towards the exact configuration I need to get this sucker working?
I have followed 99.9% of all tutorials online, searched over 600 pages/forum posts for similar problems, attempted to discover various error messages through the Cli on verbose 96 (or something near), checked /var/log/asterisk/full, checked the pri debug, checked the sip debug, searched all errors contained in there and attempted fixes based on the results, but I still get the same response messages when dialling out to my mobile phone.

I’ve rang Chess (our middle-man to BT) and they’ve run tests and can see our line is still active, although they can’t get access to any call logs/monitoring systems until 6 days after a fault has been logged (obviously that’ll be next weeks move) and BT refuse to help us without sending out an engineer (minimum cost £115).

Here are my current configs (which responds with ‘The number is not answering’) - Chan_dahdi.conf - dahdi-channels.conf - extensions.conf - system.conf - call log

If anyone could point me in the right direction - I’ll paypal you a beer



Have you engaged Digium’s Support department?



Yeah I have, Posted here, Digium Support, FreePBX distro Support forums at pretty much the same time to yield the best results.


Very late reply from me.
But i am curious.

My bet: It was the Telcos fault.