Help installing Asterisk, FreePBX, Zaptel Drivers on CentOS

Hi - I’m brand new to Linux, Asterisk, and FreePBX. I’ve been trying for over week now to get a freePBX box running. I’ve tried everything (except what works obviously).

I now have a box with a fresh install of CentOS 5.4. It has a Digium TDM2400P analog card with a single 4 channel FXO module installed. I currently have 2 POTS lines connected to the card.

I’ve tried the Asterisk NOW installation but only to have errors. I’ve tried to load CentOS then Asterisk, then FreePBX using some instructions found here in the forum without avail.

here are the instructions I tried: … l-proces….

I’ve now found a script that supposidly installs Asterisk, Zaptel Drivers, and FreePBX but I’m not even sure how to run the script or what changes to make to the script to accommodate my variables such ass passwords, ip address of machine etc… …and then I have no clue on how to even configure the zaptel device.

here’s the install script: … all-script

So now I have this box with CentOS and the Digium card in it? What’s the next step.

Help would really be appreciated. I’m totally lost here and would like to get this PBX system up so that we can use IP/Soft phones to dial out on our POTS lines.

Thank You in advance!


You need to provide details of the specific errors. At exactly what step does it fail? What did you do for that step? What did you expect to happen? What actually happended? What do the debugging logs show happened?