408 - Request Timeout (with X-Lite)

I have either exhausted my time or my patience on this one.

I’m getting the 408 - Request Timeout error when trying to hookup with an AsteriskNOW installation, which has been otherwise unmolested.

I’ve created the extensions, per multiple examples I found on the net, and configured X-lite likewise, but it won’t connect at all. It timesout.

Now, either port 5060 is blocked (it doesn’t appear in netstat -a, but also isn’t blocked by iptables, which is still the default), asterisk isn’t connecting to it (again, not in netstat -a), or X-lite is misbehaving.

I spotted this in X-lite’s debug log:

“host=” seems fishy! I expect an IP there.

Oh, and I’m running in VMWare, but I can ssh into the asterisk, and also ping it, with no problems, so I know networking in the vm is working.

Any ideas?


My heart - it weeps.

I’ve disabled firewalls on both ends of the connection, and I still get a 408. I can’t find any helpful log indicating WHY i’m getting a 408, and certainly no clues as to how to fix it. The set-up is straight forward.

Shall I just start over?

I am having similar problems (look here: forums.digium.com/viewtopic.php?t=64006)

It is really a pitty that asterisk seem to have many “boogy-traps” when trying to configure it for remote connections.

Thats what I am going to do… coz according to many blog entries it seems to work just fine… :unamused:

I rebooted, and it suddenly worked.

Man, that’s tough. I figured restarting the asterisk server was enough. I’m not used to rebooting linux installs.

not yet able to resolve. but I am now pretty sure it has to do with my to network interfaces.

single interface => works
two interfaces => does not work anymore…