(Newbie) X-Lite & Asterisk - Error 408 - Request Timed O

Hi Guys & Girls;

I’m a bit of a newbie (hence the title) but I have a good grasp of Telephony and have been working with Asterisk for a good few weeks now.

I can’t seem to get around the error above (408) when trying to liase X-Lite’s soft phone with Asterisk.

Originally, I set one machine up to be the Asterisk server, (under Fedora 7) and attempted to connect (Using X-Lite) from another XP machine in my house. I configured the SIP.conf and extensions.conf to allow the single device, after hours of research to make sure I had the syntax etc right.

No dice.

Then, I downloaded the Trixbox virtual machine from the website (for those not familiar, this adds the freepbx frontend to asterisk) to make sure that anything I was missing config-wise would (hopefully) be taken care of by the GUI.

No dice.

I have configured the system correctly as far as I can tell, and have made sure the phone and server match up. I have tried using the extension and the display name as the login details, but neither seems to work. A packet trace with Ethereal suggests “Destination Unreachable: Port Unreachable” although I swear I have recorded the same port in both the server and also in the softphone. (The unreachable message comes when the softphone is attempting to contact the server, if I am reading this right)

Can someone please suggest anything else I may be able to try? I have done plenty of research, and most seem to get past this stage, and the trixbox team themselves just keep telling me to check the configs are the same. Should you deign to point the finger at trixbox itself, bear in mind I have tried native asterisk without a frontend, and it still comes up with the same response.

Any help is much appreciated.

Sorry about the long-windedness of this post.


Check the status of the firewall, it could be blocking the sip port.


Marco Bruni

Thanks for the suggestion, but both firewalls have been disabled, and it still doesn’t work.

Any other ideas?