Call Failed: 408 Timeout

Hey guys,

I’ve installed here at my work Asterisk at a CentOS computer. I’ve done exactly how it says to do at the book “Asterisk The Future of Telephony” from Jim Van Meggelen, Leif Madsen & Jared Smith.

But now i’ve got a problem, every call I try to do, whatever the number I dial it gives me the error “Call Failed: 408 Timeout”. I’ve tried everything but I have no clue what to do. I’m using X-Lite to dial.

Can anybody help me?

Ps: please, excuse my poor english, it’s not my native language.

Just an information, Asterisk and X-lite are in the same computer.

May be your current dialing context is not included in extensions.conf .

You may ensure this by looking at the asterisk cli, that no asterisk messages can be found when u dial.


Thx for the help but it didn’t work, still going in error 408 whichever number I dial

but in one thing you were right, when I dial, nothing happens at asterisk CLI

when I digit the command ‘show sip peers’ it shows me 0 sip peers.

My deadline is almost over and my boss is after me about this thing, I need help urgently.

you are running both x-lite and asterisk on the same machine… correct? have you configured one or the other to NOT use the standard SIP port of 5060?


A 408 is normally the set hasn’t registered, I think you are goint yo have to go to your Boss and explain. Its a bit much for him to expect you to just be able to get a PBX running with just a book.



No, I’ve not configured them to not use the standard port

anyone has any ideas?


The obvious is to use standard ports and check that the basic config is working before making any changes.
This way you will know where the problem is.


Both the x-lite softphone AND asterisk are running on the same machine… one of them needs to give up the port.


still not working, everything else is working fine, except dialing/receiving calls.

Anyone else has any other clue?


You are expecting a lot, to tell whats going on we need to see debug out put from a call that fails. anything else is guesswork.