X-lite registration problem

I have installed asterisk on server A. The system is lying in my office but have public IP. The server in not on my local network. When I try to connect to asterisk through X-lite, it connects to asterisk and works fine. But when I try to connect to asterisk from home through internet, it fails to register displaying message “Registration error: 408- Request timeout”. I have tried with alot of in sip.conf and changing options in X-lite but could’nt find any solution. please if any body can tell me about sip.conf settings and X-lite settings. i will be grateful.

I had the exact same problem and it was driving me crazy.
So I played with the settings until I found something that worked.

Under SIP Account Settings go to Properties of your account.
Under the Account tab, I put in:
Under display name: Full Name
Under User name: extension (mine is 1000)
Under Password: mypassword
Under authorization user name: extension (same as above, 1000)
Under domain: IP of the server running asterisk
Check Register with domain and receive incoming calls.
On send outbound via, select proxy and put your ip that you put above under domain.

Now under the tab Topology under IP address I changed Discover global address to Use local IP address.

Then save it and give it a try.
That should fix your timeout problem.

I have tried with these settings but still facing the same problem. I dont know if i have to make some changes in network settings or something else. I am stuck.

The major problem you are having is a network issue, your server is not on the same subnet with your host (your PC) just get your PC on same subnet with the asterisk server then you are good to go

thanks for your replies. I got the problem solved. I installed iptraf-3.0.0-1.0.rh9.rf.i386.rpm on asterisk server (Centos). Then i sent ping request from remote server to asterisk server. iptraf was showing traffic from remote server. Now i installed “UDP Test Tool 2.5” on remote system (windows) and sent some message to asterisk server on udp port 5060. The iptraf was showing no request comming from remote server. So i concluded that the problem is that the sip request is not reaching the asterisk server. I contacted my internet service provider and they said “yes you will have to make a request to open udp ports”. So i completed the formality and they opened udp ports. Now my problem is solved and the soft phone is registering from remote server. once again thanks for your replies.