Zaptel running on CentOS 5 server - WILL PAY FOR SOLUTION

We are having problems installing zaptel so our meetme conference rooms will work with Asterisk.

We have no troubles installing to CentOS 4, so it may be an issue with CentOS 5 keeping the kernel source in a different location.

We have tried a number of things:
yum install -y kernel kernel-devel
yum install -y newt-devel libusb-devel kernel-devel-2.6.18-53.el5

Normal install did not work also:
wget … .11.tar.gz
tar -zxvf zaptel-1.4.11.tar.gz
cd zaptel-1.4.11
make install
modprobe zaptel
modprobe ztdummy

The error we get is as follows:
echo "You do not appear to have the sources for the 2.6.18-53.el5 kernel installed."
You do not appear to have the sources for the 2.6.18-53.el5 kernel installed.

I would like to have someone show me how to install zaptel on our server.

Can anyone please advise how quick they can do this and how much it will cost me.

If anyone has documentation on how to do this then can I buy it from them, as this is all I really need.

My servers are located with GoDaddy if this information helps.

If there is any information that would help please let me know what you would like.

You may also contact me on +61402992177 or +61884433155 (0402992177 or 0884433155).

do you either have a copy of the kernel source or a symlink to it in /usr/src/kernels?

ln -s /usr/src/kernels/2.6.18-53.1.21.el5-i686 linux

Is the link I did and has not helped.

Any other suggestions are welcome.

folder with your current kernel (uname -r) must contain symlink ~build to your kernel source, because in Makefile:

# If you want to build for a kernel other than the current kernel, set KVERS
ifndef KVERS
KVERS:=$(shell uname -r)
ifndef KSRC
  ifneq (,$(wildcard /lib/modules/$(KVERS)/build))
    KSRC_SEARCH_PATH:=/usr/src/linux-2.4 /usr/src/linux
    KSRC:=$(shell for dir in $(KSRC_SEARCH_PATH); do if [ -d $$dir ]; then echo $$dir; break; fi; done)

I am not sure what you mean by your code? Where do I put that.

One thing I have tried to do is:
rm /lib/modules/2.6.18-53.el5/build
ln -s /usr/src/kernels/2.6.18-53.1.21.el5-i686 /lib/modules/2.6.18-53.el5/build

Then run the normal install of the ZapTel and I then get this error: (last 5 or so lines below) When running #make

Make[4]: *** [/root/zaptel-1.4.11/kernel/xpp/card_fxo.o] Error 1
make[3]: *** [/root/zaptel-1.4.11/kernel/xpp] Error 2
make[2]: *** [module/root/zaptel-1.4.11/kernel] Error 2
make[2]: Leaving directory /usr/src/kernels/2.6.18-53.1.21.el5-i686' make[1]: *** [modules] Error 2 make[1]: Leaving directory/root/zaptel-1.4.11’
make: *** [all] Error 2

Ok this is interesting…

The post I just made about those links…

Before making those links I had hashed outline 117 of my:
file as I had been told this needs to be done.

I now find that if I unhash this I can do the “make” command and also the “make install” command.

But then when going to execute the “modprobe zaptel” command I get this error:

modprobe zaptel

FATAL: Module zaptel not found.

So anyone for any ideas on what to try now?

You shouldn’t need to manually change any symlinks… I actually just did a CentOS 5 install a few days ago…

Can you show us the output of:

$ rpm -qa |grep kernel $ uname -r
You might also need the ‘kernel-headers’ package.

If you recently upgraded your kernel (which could have happened automatically without you realizing), you’ll need to reboot the system so everything is in the right place (at least, that’s the easiest way to make the compile work).

Outputs as requested:

rpm -qa |grep kernel


uname -r


Please let me know what to try next.

it’s look good :smile:
what was the last message before your

Make[4]: *** [/root/zaptel-1.4.11/kernel/xpp/card_fxo.o] Error 1 make[3]: *** [/root/zaptel-1.4.11/kernel/xpp] Error 2 make[2]: *** [_module_/root/zaptel-1.4.11/kernel] Error 2 make[2]: Leaving directory `/usr/src/kernels/2.6.18-53.1.21.el5-i686' make[1]: *** [modules] Error 2 make[1]: Leaving directory `/root/zaptel-1.4.11' make: *** [all] Error 2

Ah ok, you have the latest kernel headers but still have and are running a slightly older kernel. You’re having problems because they don’t match up.

Actually there is a new kernel in updates anyway… so your best bet is to do a:

# yum upgrade -y kernel kernel-devel kernel-headers

reboot, and you should be fine.

Ok this is not good, I just did #shutdown -r now and the server is not coming back up…

I am going to do a re provision of everything to bring it back to fresh CentOS 5 install with GoDaddy.

If you can maybe line for line let me know what I should copy and past to get it to work that would be great. (that is what normally works).

The re provision normally takes them a few hours, so I would not be back on till morning.

Try this
1.make menuselect
2.Kernel modules
3. uncheck ALL
4. make
5. Results OK?

Answer: Yes
6. try check in Kernel modules what d’you whant to install
7. make

Answer: No
6. Give us the complete error message

Ouch, good luck. On the new install you really shouldn’t have to play with symlinks or move important files… the rpm’s are enough.

Note, the very latest kernel stuff in updates (2.6.18-92.1.1.el5) does require you to comment out the bool typedef in xdefs.h like you did before (whereas the kernel you were running before, 2.6.18-53.1.21.el5, didn’t require this).

You can use any kernel version you like… as long as you have ‘kernel’, ‘kernel-devel’ and ‘kernel-headers’ (check with ‘rpm -qa | grep kernel’) installed for the same version as your running kernel (check with ‘uname -r’). If that’s the case you really shouldn’t have a problem to compile, install, and run zap, asterisk, etc.


I exactly had your problem couple of times. I really don’t know it is right way

As said in earlier post ur kernel-devl and kernel doesn’t match up

  1. Yum remove kernel-devel

  2. yum install kernel-devel-2.6.18-53

(or u can update the kernel to the latest version(i mean to the exact version of wht kernel-devel is installed)

Let us know how it went. Hopefully this will solve your issue.


Ok the end result was that GoDaddy must change something with Centos install, they must disable or do something to yum that stops all the suggestions that have been made from working.

The work around that has been found is as follows:

GoDaddy servers require the following before the below will work.

rm /lib/modules/2.6.18-53.el5/build

ln -s /usr/src/kernels/2.6.18-53.1.21.el5-i686 /lib/modules/2.6.18-53.el5/build

Update zaptel version in command below as required:

cd ~
wget … .11.tar.gz
tar -zxvf zaptel-1.4.11.tar.gz

Update zaptel version in command below as required:

cd ~
cd zaptel-1.4.11

GoDaddy servers require the following before the below will work.

cp -rf /lib/modules/2.6.18-53.1.21.el5/misc/ /lib/modules/2.6.18-53.el5/kernel/drivers/misc/zaptel/

make install
modprobe zaptel
modprobe ztdummy
make config

Replace your own kernel version with the ones from what I had above and your a go.
Just look in the folders on your servers and its easy to work out what to change it to.

Need any help PM me…