Cant compile zaptel on CentOS 5.2

Hello everyone,

Good day!
Its my first to time to deal with projects pertaining to asterisk and linux so what I did inorder to have my asterisk running, I just followed all the steps given by the pdf document I got from Other installations were doing fine however when executed/compiled the zaptel module via ‘make’ command, I got this error ->

[root@localhost zaptel-]# make
make[1]: Entering directory /usr/src/zaptel-' echo "You do not appear to have the sources for the 2.6.18-92.el5PAE kernel installed." You do not appear to have the sources for the 2.6.18-92.el5PAE kernel installed. exit 1 make[1]: *** [modules] Error 1 make[1]: Leaving directory/usr/src/zaptel-’
make: *** [all] Error 2
[root@localhost zaptel-]#

I browsed the internet with regards to this one and followed their solutions however it only gave another set of errors. Is there anyone from here who has an idea how to resolve this one?I know this should have been posted to other sites however since it is also dealing with zaptel and since zaptel is one of the modules needed by asterisk, that is why I tried my luck to seek for answers here.

I am using CentOS 5.2 and asterisk, libpri and zaptel versions 1.4.(updated versions).

I already tried to install the rpm source for the kernel but unfortunately zaptel is still looking for the kernel source. Please help me, anyone?

Thanks in advance!

Hiya, I had a similar problem recently. I mainly use FreeBSD, but wanted to try a few things out on Linux and chose CentOS.

I used the following page : … stallation

After i’d run the yum -y upgrade and rebooted, Zaptel installed just fine.