Install TE405

Trying to install TE405 card. Does not appear that zaptel is installed. When I try to make zaptel, I get an error saying kernel sources are not installed. I have done a yum install kernel-devel and rebooted.

Still get the same error doing a make

are you using centos as distro then you need to make an symbolic link before installing zap, centos installs the sources to another directory and zaptel is looking for /usr/src/linux you need to look at the lcation of your sources probably it’s in /usr/src/kernels/“version”

goto /usr/src and make a link

ln -s kernels/“version this must be the same as your current kernel uname -r” linux

Not sure if this will help or not. My first Asterisk install was on Slackware and everything compiled on the first try. When I re-installed on a Debian Linux, I couldn’t compile Zaptel until I ran the following:

apt-get install linux-headers-uname -r bison openssl libssl-dev libeditline0 libeditline-dev libedit-dev

apt-get install gcc make g++ php5-cli mysql-common libmysqlclient15-dev libnewt-dev

Good Luck,


Gave up on zaptel, upgraded and moved on to dahdi. After some gyrations, got dahdi to work. Suggestion, download and install dahdi-linux and tools separate. The complete package hosed on me.