Zaptel drivers


#1

I have just purchased a TDM400, but the letter with it says the zaptel drivers don’t work with it, and I have to get a driver from www.asterisk.org
The command ‘modprobe wctdm’ etc etc, made me assume the driver was named ‘wctdm’ however I cannot find a driver with this name.
Also, if I find the driver, where do I put it, because modprobe obviously expects it to be in a certain place. I assumed that the card supplier would supply any required drivers but obviously I was wrong, they don’t see that as part of their responsibility.


#2

I went through the same thing. I suggest you start here:

http://www.voip-info.org/wiki/view/Asterisk+Zaptel+Installation

This will show you how to compile the drivers, and the drivers will be put into the correct directory for your Linux distribution.

At that point, you should be able to execute:

modprobe zaptel
modprobe wctdm

At some point, you will want the drivers to load automatically when your system boots up. So, you’ll execute this command as described in the tutorial above:

make install

This will put a script somewhere in your system (in my system, it was in /etc/init.d) that needs to be called when the system boots up. You will have to figure out how to be sure that script gets called at boot up time on your own as it is dependent on your Linux distribution. I am using Ubuntu, which is based on Debian, and I was able to figure it out pretty easily.

Good luck!


#3

Thankyou, that’s way more info than I got from the card supplier.
They gave me a one line ‘modprobe wctdm etc’ preceded by the statement that zaptel drivers don’t work with this card.
I see you have used modprobe for both wctdm and zaptel. Did your installation not work without the modprobe zaptel ?


#4

I never tried it without the ‘modprobe zaptel’. My assumption is that you must load the zaptel module just to support the zaptel interface, and then you must load the wctdm just to support the TDM400 itself.

If you do a ‘make install’, it will create the script to load both (figuring out how to get the script to run when your system boots up is the tricky part).


#5

Thanks for the help, unfortunately it hasn’t made any difference. I’m still not in ‘AUSTRALIA’ mode and I have no idea what to do next. I’m currently following the instructions on one of Digiums pages, I think it is re-installing Asterisk. But I’ve just noticed further down in the instructions that I still have to install the drivers, and that is what I thought I was doing. It’s just too hard, I’m about ready to give up and send the gear back to the supplier and get my money back. :frowning:


#6

When something go wrong…
DO NOT give up! (See Blues Clues)

Below is a short proc I wrote while ago and used quite smooth:
Assuming version 1.2.0 - simply use your version instead the ones in code:

Building asterisk (After you doenloaded the sources in gz format)

Modules/Files we use:
asterisk-1.2.0.tar.gz
zaptel-1.2.0.tar.gz
libpri-1.2.0.tar.gz
asterisk-sounds-1.2.0.tar.gz
asterisk-addons-1.2.0.tar.gz

  1. We start with the zaptel module – This is done by root!!
    cd /usr/src
    tar zxvf zaptel-1.2.0.tar.gz
    cd cd zaptel-1.2.0

make clean
make
make install
Optional: make config (So the driver willbe loaded auto at init)
CAUTION: If you do make config take care to edit /etc/sysconfig/zaptel and comment
ALL drivers you do not use!!!

  1. Install the libpri (Used for PRI/E1/ISDN)
    cd /usr/src
    tar zxvf libpri-1.2.0.tar.gz
    cd libpri-1.2.0
    make clean
    make
    make install

  2. Installing Asterisk main
    Note: You may edit the Makefile to modify several options per your need

cd /usr/src
tar zxvf asterisk-1.2.0.tar.gz
cd asterisk-1.2.0
Note: You may edit the Makefile to change several options
make clean
make mpg123
make
make install
make samples (This is important, will create all sample files!)

  1. Installing asterisk-sounds
    cd /usr/src
    tar zxvf asterisk-sounds-1.2.0.tar.gz
    cd asterisk-sounds-1.2.0
    make install

  2. Installing addons
    Cd /usr/src
    tar zxvf asterisk-addons-1.2.0.tar.gz
    cd asterisk-addons-1.2.0
    make clean
    make install

  3. Update udev so zaptel driver can access the PCI TDM/T1 cards etc…
    Add the lines below to file:
    /etc/udev/rules.d/ 50-udev.rules

KERNEL==“zapctl”, NAME="zap/ctl"
KERNEL==“zaptimer”, NAME="zap/timer"
KERNEL==“zapchannel”, NAME="zap/channel"
KERNEL==“zappseudo”, NAME="zap/pseudo"
KERNEL==“zap[0-9]*”, NAME=“zap/%n”

  1. At this point you may try to load the zaptel driver and run Asterisk
    modprobe -v wctdm (for TDM400P) (For other modules use other drivers)
    asterisk -vvvvgc

You should get at the end a prompt like:
== Registered application ‘Verbose’
== Manager registered action DBGet
== Manager registered action DBPut
== Parsing ‘/etc/asterisk/enum.conf’: Found
Asterisk Ready.
*CLI>

GOOD LUCK!


#7

I really appreciate that you are trying to help, but I don’t have all these files or any other files for that matter. I have an auto install version of aah 2.7. It autoboots, formats the harddrive, installs and builds aah all on its own. I have no idea what versions of what files are used other than it uses CENTOS 4.something and aah 2.7. I do have instructions that came with the CD to set up the card for AUSTRALIA, however, at the end of the instructions, it is still set for North America. I followed a set of instructions on the NERD VITTLES site which stopped aah dead. I am definitely not experienced enough to attempt to find these files and install by hand. To date all attempts at manual installation of any program (even very small ones) have been met with total failure. So the bottom line is, if it won’t work from an auto install CD, I have very little chance of making it work. The only consolation I have is that I can still learn how to use aah even though the Pstn speech quality is poor.


#8

[quote=“zvika”]When something go wrong…

CAUTION: If you do make config take care to edit /etc/sysconfig/zaptel and comment
ALL drivers you do not use!!!

GOOD LUCK![/quote]

Is this correct for the TDM11B? (file: /etc/sysconfig/zaptel)

Directory: Hardware/Telephony

Description: Zaptel Modules

Type: sting

Default: “”

Config “”

ServiceRestart: zaptel

This is a space saparated list of zaptel modules to be

loaded. Valid module names are:

qozap, tor2, torisa, wcfxo, wcfxs, wct1xxp, wct4xxp,

wcusb, zaphfc, ztd-eth.

ZAPTEL_MODULES=wct1xxp (with quotation marks or without quotation marks ??)