[FIXED] - Can't get Zaptel to talk to TDM400P

I’ve got a Dell PowerEdge 500C Tower here with a 1GB of Ram and a decent CPU.

Just reacently acquired a TDM400P Card (which is installed) and now I’m trying to get the computer to talk to it.

Oh and this is a Fedora Cora 5 system with a healthy stock kernel running at 2.6.17

Zaptel successfully compiled and installed but I am unable to use the ztcfg program to configure it.

[code]# ztcfg
Notice: Configuration file is /etc/zaptel.conf
line 0: Unable to open master device ‘/dev/zap/ctl’

1 error(s) detected

So I look in my O-reily book and see that I need to modprobe to get the card installed or loaded into the kernel.

# modprobe wtcdm FATAL: Module wtcdm not found.

Could realllllly use a hand here… seems like everyone else is having a snap… so It’s gotta be something stupidly simple in my case.


are the kernel sources/headers you have installed a match for the kernel you’re using ? have a look through your /lib/modules directories to see if the “make install” put them in another directory.

Matthew: one possibility is hardware. This is very similar to my experience on an IBM 300PL; dismantling the hardware and reassembling (in my case I think it was a poor connection between the motherboard and riser board that carries the PCI cards) resolved the issue.

modprobe wtcdm

It should be
modprobe wctdm

and if you have not done already you should load the zaptel
module before loading wctdm by

modprobe zaptel

modprobe zaptel
modprobe wctdm

Then reboot your system: shutdown -r now.

Now log in as root again and type amportal stop and then genzaptelconf.
Reboot once more and you’re all set to go: shutdown -r now

thank you so much! I’ll try this first thing tomorow morning!

:slight_smile: Wasn’t expecting so many replies… very nice.

PS: Im a bit dislexic… so i’ll be sure to watch my typing a bit.

Ok… tried the above…

1: Modprobe Zaptel yieled an error like the wctdm one did.

2: Modprobe wctdm didn’t work either…

3: Looking in the modules… didn’t quite locate the specific files that should be there? Could you be a bit more specific?

Tried re-installing zaptel numerious times… somethings not right : O /

Rebuilt system… found a couple more things but managed to plow through im.

Thanks for the asisstance!