Xlite extensions only

I have installed the asterisknow system and the x-lite 3.0 softphone. I do not have a trunk configured as I only want this to be a local intercom system that cannot dial out.

I can register the softphone using the following settings:
Display Name: 9000
User name: 9000
Password: passowrd
authorization user name: 9000
Domain Proxy: NOT CHECKED

I cannot make any calls to any other extensions.

If I enable “Domain Proxy” and add the Asterisk server as the proxy server (, the phone will not even register on to the system.

What configuration setting am I missing to setup the X-lite softphone only for extensions, local use?

Thanks in advance,

I am by no means an asterisk expert,but, i have found that in order to learn how problems such as you are experiencing can be resolved is to open the CLI in asterisk,then run ‘sip set debug’ then try and register the phone to the already setup extension number(s). I have taught myself quite a bit of how asterisk interacts with the softphones this way. Just do a search for asterisk cli,for examples. it seems strange that you can not get the xlite softphones to register, this is pretty simple stuff provided the phones are in fact on the same subnet as the asterisk server. are you sure you have added the correct password when you create the actual extension for each xlite softphone? try changing your ip number you have entered in the xlite phone config to localhost and see if you end up with “service not available” on the xlite phone when the phone tries to register. let us know your progress.

take care

Thank you for the reply.

I can get the phones to register if I do not enable the “Domain Proxy”, however, I am not able to make a call to the other xlite phone (on another computer, same subnet and registered without the Domain Proxy enabled)

Once I enable the Domain Proxy, the phone will not register.

I will try your suggestion later this evening and update you.

Thanks again,

You don’t provide enough information to figure out how to help you.

You say you cannot call other extensions… What does the console say when you try to make a call? What does your dialplan look like, did you create extensions to dial the softphones?

I think the issues that I had was because of the Windows 7 OS. I tried doing the same configuration settings between 2 Windows XP machines and it works fine…

Thank you for your time,

Hi Mike,

That’s interesting. Maybe Windows 7 has some more stringent suedo/behind the scene firewall rules or service running that don’t let sip function without some tweaking. I am guessing many people will be experiencing the same thing starting with Windows 7, if this is, in fact the case.
Thanks for keeping us posted,anyways,food for thought.

Take Care,


I am having the exact same problem but even if I use XP the phone only register when I set not to register.

This is happening with Xlite or when using an ATA. So the problem is probably in the asterisk settings.

Here is my extensions.conf
exten => 1000,1,Verbose(1|Extension 1000)
;exten => 1000,n,Echo()
;exten => 1000,n,Hangup()
exten => 1000,n,Dial(SIP/1000,30)
exten => 1000,n,Hangup()

exten => 1001,1,Verbose(1|Extension 1001)
exten => 1001,n,Dial(SIP/1001,30)
exten => 1001,n,Hangup()

include => internal

and sip.conf

I am not setting a password .

Any help will be appreciated.


Jair Santos