Asterisk and Xlite


I have recently installed asterisk- and am trying to register X-Lite softphone running on another PC. I have defined extension.conf and sip.conf (mentioned below).
Still i am not able to register X-Lite with asterisk.Please help





exten => s,1,Verbose(1|Unrouted call handler)
exten => s,n,Answer()
exten => s,n,Wait(1)
exten => s,n,Playback(tt-weasels)
exten => s,n,Hangup()


exten => 500,1,Verbose(1|Echo test application)
exten => 500,n,Echo()
exten => 500,n,Hangup()


include => internal





You need a secret or to disable authentication.

How can i do that??
i am not getting your point…


By default, Asterisk will not accept unauthenticated registrations. You must either configure it to allow them, as detailed in a recent thread, or provide a password in both sip.conf and the phone.


I have modifies sip.conf as follows and trying to register with 12345 as client but still it does not work

[12345] ; X-Lite client 12345
nat=yes ; we assume clients are behind NAT
host=dynamic ; and have dynamic IP addresses
reinvite=no ; if so, we need to make them
canreinvite=no ; always go through Asterisk
callerid=“Fred Flintstone” <12345>
allow=gsm ; add whatever other codecs we fancy
context=theflintstones ; use a context that exists :wink:

Get a SIP trace with sip set debug, tcpdump, wireshark, etc.

On Xlite…i am getting request time out…408

Plz help with this issue

I’m not clear what is sending the 408 and I’m certainly not clear to what it is responding.

i have configured sip.conf as mentioned in the prevoius post.than i run command “dialplan reload” and “sip reload”.Now when i try to register xlite with userid 1000 , it shows request timeout that means it is not registered with asterisk

It shouldn’t send anything if it fails to register. The only valid response on the wire from the client to a failure to receive a reply to a register request is another register request. The 408 is probably a virtual 408 that never goes over the wire. That would indicate that either Asterisk never received the request, or that its reply failed to reach the phone.

We need to see the actual SIP protocol exchange.

At the moment, I would have to assume a firewall problem. It could also be because the Xlite is quoting an invalid public IP address. Xlite does work with Asterisk.

I am trying to configure it using GUI now.

I am installing Asterisk GUI from

after configuration when i run command “make checkconfig”, i get the following output

[root@asterisk ~]# cd asterisk-
[root@asterisk 2.0]# make checkconfig
— Checking Asterisk configuration to see if it will support the GUI —

  • Checking for http.conf: OK
  • Checking for manager.conf: OK
  • Checking if HTTP is enabled: FAILED
    – Please be sure you have ‘enabled = yes’
    – in /etc/asterisk/http.conf
    make: *** [checkconfig] Error 1
    [root@asterisk 2.0]#


; Asterisk Builtin mini-HTTP server
; Whether HTTP interface is enabled or not. Default is no.
; Whether Asterisk should serve static content from http-static
; Default is no.
; Address to bind to. Default is
; Port to bind to (default is 8088)
; Prefix allows you to specify a prefix for all requests
; to the server. The default is “asterisk” so that all
; requests must begin with /asterisk

; The post_mappings section maps URLs to real paths on the filesystem. If a
; POST is done from within an authenticated manager session to one of the
; configured POST mappings, then any files in the POST will be placed in the
; configured directory.
; In this example, if the prefix option is set to “asterisk”, then using the
; POST URL: /asterisk/uploads will put files in /var/lib/asterisk/uploads/.
;uploads = /var/lib/asterisk/uploads/