WrapUp Time is not working any more

Hi guys, I need some help here.

Wrap up time just stop working. It was working fine but not any more. I can’t figure out why!

I saw many post about it, but nothing like this. Queues are very easy to configure. Maybe you can give me some help.

Thanks in advance!

[201]
announce-frequency=0
announce-holdtime=no
announce-position=no
autofill=no
autopause=no
autopausebusy=no
autopausedelay=0
autopauseunavail=no
eventmemberstatus=yes
eventwhencalled=yes
joinempty=yes
leavewhenempty=no
maxlen=20
memberdelay=0
penaltymemberslimit=0
periodic-announce-frequency=0
queue-callswaiting=silence/1
queue-thereare=silence/1
queue-youarenext=silence/1
reportholdtime=no
retry=5
ringinuse=no
servicelevel=45
setinterfacevar=yes
strategy=rrmemory
timeout=30
timeoutpriority=app
timeoutrestart=no
weight=0
wrapuptime=30
[from-agentes]
exten => _17XX,1,Noop(Calls TO AGENTS)
exten => _17XX,n,Dial(SIP/${EXTEN},25,tT)
root@sasasa# asterisk -rx"queue show 201"
Setting max files open to 4096
201 has 0 calls (max 20) in 'rrmemory' strategy (52s holdtime, 288s talktime), W:0, C:28, A:13, SL:57.1% within 45s
   Members: 
      mortega (Local/1718@from-agentes from SIP/1718) (ringinuse disabled) (In use) has taken 5 calls (last was 162 secs ago)

I’m sorry I forgot the asterisk version: 11.16.0

I see that your agents are added as local channels. Does it change anything if you add the SIP device directly? (As in SIP/1718 rather than Local/1718@from-agentes)

Asterisk 11 is almost two years past end of life (and three years since general fixes were applied).

Thanks for reply.

I didn’t try. But as I said: It was working fine and I didn’t change anything. Maybe you know where should I look.

Thanks for reply.
Ok david, you’re right: Asterisk 11 is a bit old. This Asterisk was working fine since 2017. I have this issue now. Maybe you can tell me where should I look.

Something changed. It might not have been you, but something has to have changed. I don’t think I’ve ever heard of a bug where queue’s behaviour changed out of nowhere, except in the case of a change of queue strategy.

Have you tried doing a queue show immediately after the agent hangs up a call, to see what the agent status is during and after the wrapup time? If memory serves, it should be ‘unavailable’ during the wrapup time.

Worst-case, you could always try a full core restart off-hours to see if that brings it back…

Are you sure about this? I have never seen that. In fact, I have another system (for testing) and same configuration than production. Wrap up time is working there and I don’t see “unavailable” on “queue show xxx”.

No, not sure. I manage several different voice platforms and the features of each are kind of a blur. I’ll check in my lab when I get a chance. Seems logical that it would at least show as “In Use” or “Busy” or something, to indicate it’s not yet Idle because it’s wrapping up.

BTW, why autofill=no? I’ve never seen anyone use that.
Other things I might consider:
memberdelay=0 and penaltymemberslimit=0.
I don’t know if explicitly specifying these values is the same as leaving them commented out, and I’m not sure how these features would interact with wrapuptime as I’ve never tested them together.

Yes, I know. I changed that because extensions was receiving more than one call per time. I KNOW that autofill IS NOT FOR THAT, but my queues started to operate weird and “autofill = no” was the only way I found to give my agents some breath. With NO wrapup and more than 1 call per time… you can imagine.

The extensions are configurate with “Call Waiting = Disabled”. Of course, FreePBX.

That is VERY weird because ringinuse=no should handle that, and it’s possibly symptomatic with your other problem.
I assume the answer is yes, but it’s worth asking; Have you CONFIRMED that the calls in question are going through the queue and no bypassing it and calling the extension directly?

If it’s going through the queue, that would mean that you’re no longer able to track the device’s INUSE status correctly. This brings us back to my initial question regarding the use of local channels. If you set a hint against that channel (Local/1718@from-agentes) and against the SIP device (SIP/1718), what does “core show hints” show for the BLF status when that user is on a call (both in and out of the queue)?

fbeaulieu, thanks for replying, appreciate it.

Yes!!! I thought the same.

Yes, confirmed!

What “core show hints” shows is correct. As you can see:

1718@ext-local           : SIP/1718&Custom:DND1  State:InUse           Watchers  0

The state is correct: “InUse” and Idle when it is not in call.

I understand what you are saying. But I can tell you, in testing is working fine. In fact, just a month ago was working fine.

Is your instance of Asterisk installed by package management? If so, is it possible that it applied a minor upgrade recently or something? Also, 11.16.0 is not the latest version in that train. Have you tried testing against 11.25.1 just to see?

Yes, of course. But -and I’m sorry for saying all the thing again- in testing, same asterisk version, same FreePBX version, same EVERYTHING and it works!

Ok, just one little thing I discovered:
callcounter
In testing callcounter is YES; in production callcounter is missing…

I have changed that now.

Wiki says: The callcounter option in sip.conf must be enabled for SIP devices (e.g. SIP/Alice) to provide advanced device state. Without it you may see some state, such as unavailable or idle, but not much more.

That could certainly explain things. In any case, you might be better off discussing this on FreePBX forums as they’re more likely to be aware of the little quirks of how things are configured out of the box.

Thanks fbeaulieu! It is not solved.

Anyway, I don’t think that FreePBX forums will help me more than here. I believe this is an Asterisk issue.

Ok guys!

The last I said did the trick.

callcounter=yes

I don’t really know why but it was that.

Thanks everyone.