Would like to run sip show registry from DB

I am using ARA and my existing setting does not allow me show anything while running the below command

sip show registry

extconfig setting:
sippeers => odbc,asterisk,sippeers
sipusers => odbc,asterisk,sippeers
extensions => odbc,asterisk,extensions

Please help me.

The chan_sip module does not support pulling this information from the database using the CLI commands.

Ok, I see… But calls are also not landing on asterisk from sip provider

I’d suggest providing further information about your setup then. For example: the console output, the configuration, whether you are registering or not, the result of “sip set debug on”.

Hi Jcolp,

If I put the below setting in my extconfig then the call lands properly on my Asterisk 11

sipusers => odbc,asterisk,sip_buddies
sippeers => odbc,asterisk,sip_buddies
extensions => odbc,asterisk,extensions
sip.conf => odbc,asterisk,sip_reg

But If I put the below settings, no calls coming and no sip set debugging on working as the sip provider says we are not able to find client machine and which is working on user based registration
sipusers => odbc,asterisk,sip_buddies
sippeers => odbc,asterisk,sip_buddies
extensions => odbc,asterisk,extensions

So no logs are there on asterisk.

Please suggest

Outbound registrations must still be placed in the sip.conf file. Are you not doing this and thus chan_sip is not registered?

I am realtime dynamic so outbound registration is working fine without any issues and data is in sip_buddies table but for inbound sip registration is not working

I think you have those reversed. Inbound works fine with realtime, but outbound still requires sip.conf. If you aren’t registering outbound then you will see the behavior you see. No traffic from the SIP provider as they don’t know where you are.

Yup sorry actually I used term in a wrong way, I meant outbound call are working but not inbound call working, so Outbound registration is not working, can you please help me on this?

As I mentioned you have to put the outbound registration in sip.conf, whether that is stored in the file or using static realtime it doesn’t matter. It can not be in dynamic realtime.

OK great thanks…I can use static Realtime but in that I am unable to modify the listening sip port, can u please guide me how to change from 5060

The port is changed in the general section, just like in sip.conf, using the bindport field.

But it is not working as expected. I do not know may I am missing something else

What have you put into the database, what does “sip show settings” show, and what is the current contents of extconfig.conf?

For static Realtime I m using the below line means all conf of sip file will be picked from the sip_reg table but then it is not taking the port from bindport of sip.conf…am I doing something wrong here?
sip.conf => odbc,asterisk,sip_reg

You have to place the data into the sip_reg table. You CAN NOT use both the sip.conf file itself and have it pull from the database.

But port in not pulling out from db I guess that is why it is not taking the port I mention in the table sip_reg

If I don’t want to use sip_reg table and point sipusers family to my existing sippeers table…will it work?

Not working by putting bindport field in sip_reg table as it is again reading from sip.conf default port 5060 and I have changed the port in db sip_reg table

You’ve changed stuff around a lot and I have no idea anymore how stuff is configured. Please provide the configuration as well as table schema and contents.