Voicemail PW issue

I am trying to login to my voicemail and after I enter the pw I get Password incorrect. I also see a vm_authenticate: couldn’t read username error on the console. Any ideas? this did work at one point.


Have you compared what you are entering with whats in voicemail.conf ?
And are DTMF tones being passed ?


I verified the voicemail.conf file. I even tried to change it.

Voicemail did work for me at one point. I made a change to use a macro and since this is what I get. I know i’m getting the correct mailbox because my greeting comes up so the macro seems good.

How can I verify DTMF is working correctly?



So It worked, You made a change and now it doesnt, So revert back to what it was when it worked then, Check the code.
Why do you need a macro to access vmail? its

exten => 123,n,Voicemailmain(s${CALLERIDNUM})

sort of does it.


I’ve experienced the exact same issues with 1.4.1 on three separate Asterisk boxes. All three boxes were running flawlessly for over 11 months. The day I upgraded to 1.4.1 I experienced problems logging in to both voicemail and meetme teleconferences.

When we dial in to voicemail, we’re prompted for the mailbox. Once entered, there is a long pause, then the prompt comes up for the passcode. When that’s entered, it comes back and says the password was incorrect. The only workaround is to dial back in and try again, and once every four or five calls the system will accept the codes.

I put sip debug on and watched as each key was entered. The system correctly identified each key as it was depressed, yet still came back with the error message.

Accessing meetime conferences results in the same problem - the conference number and/or pin fail.

The worst part of this is that it appears to be frequent, but intermittent.

The problem has caused a lot of irate users, and the only solution I know of is to downgrade back to 1.4.0 and take my chances…

The Macro was for dailing in not accessing voicemail. Sorry for the confusion.

I did however change my voicemail from

exten => 99999,1,VoiceMailMain()


exten => 99999,1,VoiceMailMain(${CALLERIDNUM}@voicemail)

The interesting thing is the phone isn’t registered as the same number as the voicemail box. Therefore I get an error on the console that the mailbox doesn’t exist. Then it asks for the mailbox # and pw and it works correctly.

Looks like I just need to set the Callerid number for my hardphone and softphone and that might fix my issue totally.

Thanks for your help!

as an aside, shouldn’t you be using CALLERID(num) now ? :smiley:

I believe I finally solved the DTMF issue that was causing great difficulty in entering authentication for voicemail and meetme via DTMF on 1.4.1.

My sip phones dtmfmode is RFC2833. I watched the debug output of the failed logins and found that my phone was sending the DTMF codes as SIP INFO. I disabled sending “DTMF via SIP INFO” and the problems seemed to have vanished. I’m now able to log into voicemail five out of five times, as opposed to one in five - a definite improvement.

My configs remained pretty much the same since 1.4.0, and in all previous versions of Asterisk I had the DTMF via SIP INFO set, so the upgrade to 1.4.1 obviously highlighted my misconfiguration. Interestingly enough, I also compiled an SVN branch of asterisk and the problem didn’t surface in that version either.

The bottom line is that if you’re using 1.4.1 and you have problems logging into your voicemail account don’t send DTMF via SIP INFO.