Voicemail - google voice quirk

Hello All,

Asterisk 1.8.2
I have run into an oddity.( like everyone else that posts for stuff like this,:slight_smile: )

Been using Asterisk 1.8.2 with Google Voice for about three months now without a hitch. About a week ago when calling into my extension (which is using the GV DID) I now get Google Voice mail rather than the Asterisk voicemail as I have in the past.
For example , if I shut the extension off,and make a call to this extension the GV kicks in after 5-6 rings. I can see that asterisk voicemail answered on the first ring with the "unavaliable’ message (as it should) when looking at the asterisk CLI. It appears that asterisk sends the response to GV but I never hear this now,but I do eventually get the GV voicemail pickup as I stated. After leaving a voicemail at GV I do receive BOTH a voicemail from GV and a blank voicemail at the asterisk server as well.
I did update FreePBX ,to version and possibly this has altered something? My inbound Google settings ‘appear’ to be the same though.
I have two GV accounts with two extensions and they are both experiencing this behaviour.
Possibly GV has altered their settings once again? I have not changed anything at my GV Settings options FYI.
Sorry for long post.

Thank You,


Nothing specifically wrong w/ the interconnection, as of just now. Pushed a call to a Google Voice DID, over to Asterisk, rang a SIP phone and had bi-directional audio.

Are you going straight to voicemail? Perhaps Google’s not getting your DTMF “1” ?

Howdy Hi malcomd,

After thinking about this,this is exactly what I was thinking as well.
It appears GV does not see the Asterisk voicemail reply as an DTMF response as GV continues to ring until I pickup the phone/extension. I do get two way audio just fine as before.
It is not a big deal. I just wonder what changed ,as before ,if the extension was turned off,the Asterisk voicemail would come back to the calling phone immediately. Now in the asterisk CLI , I call extension(which is turned off for test purposes) on the first ring Asterisk is sending the unavailable message( which I never hear on calling phone,),I eventually get GV voicemail after 5-6 rings and never hear Asterisk voicemail. Don’t really know how to troubleshoot this?
Like I said until a week ago, I would hear Asterisk voicemail immediately as expected.
In GV , Settings,there is really no way to disable/enable voicemail,and I have not touched GV settings,as well.
Also voicemail is working fine within internal extensions.
Do I need to add an ‘1’ in voicemail settings possibly? the voicemail has always just ‘worked’ out of the box.

Thanks again,

You need to Answer the line and then SendDTMF a 1 back to Google.


I noticed in the asterisk CLI when the asterisk server sends the voicemail response back to GV it is format of
In the past I do not remember seeing the ‘+’ at the start of the string ?
Could this + possibly be the prob?
I don’t have enough experience with dialing rules to decypher this:(

Thank You,


Thank you much for the help.
I had done my Asterisk ,GV, FreePBX setup from this link:

michigantelephone.wordpress.com/ … n-answers/

There are two ‘googlein’ examples here. I had used the first context and had also the second example in my extensions_custom.conf file, the second example being all commented out.
I commented out the first example out ( that I have been using all along) and used the second example and voicemail is working again ,strange?
The second example does in fact contain a line to send DTMF 1,the first one did not?
Working like a charm!



Yeah, the trouble is that Google will, even if you setup Google Voice not to, still require the DTMF authentication of the call. So, you’ve got to have Asterisk do it for you. Using SendDTMF works. You can also, if you’re dialing an internal phone instead of another application, dial with the D option and have the “1” sent when the SIP phone answers.