Gizmo/Google Voice - No Audio After DTMF Keypresses

Howdy brilliant Asterisk users,

Before I ask anything, I’ll first say “Asterisk Rocks!”…

CentOS 5.4, no ipchains.
No NAT, server is on publically accessible IP

I’ve been using Google Voice (GV) for a number of months now on this Asterisk system, and just in the past week I’ve been experiencing some problems with inbound GV calls whereby the caller cannot hear me.

I am configured as GV -> Gizmo5 -> Asterisk.

This ONLY occurs if the caller presses a key on their phone when my automated attendant answers (ie. pressing 0 for a different option in my IVR menu). If the user calls, and does not press any keys on their phone, then there are no problems. There are no errors displayed on the CLI running in verbose mode, just that the call is active.

I have 2 other SIP providers other than my Gizmo account configured on the Asterisk server, and am not experiencing the problem with them. Currently I’m forwarding my GV to the number of one of those other providers (which is not the way I need this to work), I want it to come in natively by Gizmo SIP.

The same issue occurs if I initiate a call via the GV web and have to navigate an IVR menu, the person that I’ve called cannot hear me. Again this all worked perfectly about a week ago.

Also, If I recall correctly a while back I read that GV only had a limit of 5 DTMF key presses before it disconnected the call; not sure if they’ve changed something recently or whether there’s something barfed on my Asterisk server.

I’ve just upgraded from this morning to, and it has made no difference. I’ve also checked all of my Firewall logs, and there is no rejected/dropped traffic.

Any thoughts or suggestions appreciated?

Thanks in advance!

Since your asterisk is on a public IP Address, I suspect no audio has something to do with CoDec. On my asterisk (through a NAT/Firewall router with a private IP Address), I have configured with a G729 as its default CoDec and no audio problems at all.

BTW, since you are using CentOS, you may want to check out this GV DialOut. It allows you to place a GV outgoing call through your asterisk as usual.

Mazilo, Thanks for the suggestion, appreciate you taking the time to respond…

With Gizmo, I can’t seem to get any other Codecs to work other than uLaw… I get the " chan_sip.c:8413 process_sdp: No compatible codecs, not accepting this offer!" error message when I don’t include uLaw… Surprisingly, not even GSM seems to work, but yet it works on my other SIP Peers. I wonder if Gizmo has hosed my account in some way…

I have G729 available on this box, and working with other peers…

Thanks for the suggestion of GVDialout, I’ve actually got it working in my system, it’s quite handy!

My Gizmo SIP Config:


Agreed. That’s why also included G711 and use G729 as the default CoDec on my Asterisk PBX system. This way, callers who only use G711 can still call to converse with me. The only problem is I will only hear busy signals (no audio messages from G5) when my outbound call isn’t answered after several rings. AFAIK, G5 has defaulted to G711 right before it’s acquired by Google.

I believe not.

BTW, since your Asterisk PBX system has a public IP Address, you can configure it with reinvite=yes. This way, all traffics on audio streams can go direct from point-to-point instead go through your Asterisk PBX system to reduce latencies. I am not sure if this has an after effect, i.e. security issues.

Ahh, I’m just wondering if Google is messing with things since they’ve taken over G5… Kinda bummed about it though, 'cause I prefer to go native SIP from GV. Now I have to forward my GV number to one of my other SIP trunks from another provider.

Tried this as per your suggestion, and get the same effect. I’m more and more convinced that it’s Google making changes with G5. Hoping that someone can confirm. I posted over on the G5 forums to see if I can get anything there too… Thanks again for your suggestions!