Asterisk answers Google Voice, sends no audio

I’ve set up Asterisk on an Amazon Lightsail instance. I’m trying to configure it to answer my Google Voice number, send a DTMF 9, and then hang up. I followed the setup instructions here,, which worked fine for logging into GV (once I OKed it on the Google Account side). Now, when I call the GV number, Asterisk answers, but I hear nothing. Here is my dialplan,

exten => s,1,NoOp()
 same => n,Wait(5)
 same => n,Answer()
 same => n,SendDTMF(1)
 same => n,Wait(3)
 same => n,SendDTMF(9)
 same => n,HangUp()

The call does get answered (nothing else is answering, and entries do show up in /var/log/asterisk/cdr-csv/Master.csv), but then I hear nothing. If I comment out the SendDTMF(1), then the call keeps ringing and eventually goes to GV voicemail, so that line works. Why don’t I hear the 9?

Google Voice may not support DTMF at that point in time. If you do a normal Playback does audio flow?

Ah yes! I was able to hear “Hello world.”

This seems to be two steps forward and one step back, though. I tried playing a recording of a DTMF 9, which I heard, but it didn’t trigger my building’s door buzzer. That must work through whatever DTMF channel that Google Voice doesn’t support.

I guess Google Voice won’t do what I need, and I should get a real VOIP line? Or something like that?

A normal VoIP provider would work. In the Google Voice case they probably never expected inbound calls like that to need outgoing DTMF.

Hmm, well I can send DTMF from Hangouts, so it might just need to happen through the XMPP protocol. I’m definitely not sure of what I’m talking about at this point, though, so I’d have to do a lot more digging to figure it out.

Thanks for you help.