Unable to connect to 8088 port in AsteriskNow


#1

Hello,
I have installed AsteriskNow 11. when im trying to hit the server with 8088 port it is throwing an error as

Not Found

The requested URL was not found on this server.

Asterisk Server

Any help will be appreciated

Note: while using port 80 its working fine.


#2

What are you trying to use on port 8088?


#3

im trying to integrate my asterisk server with an application using 8088 port. So,the application throwing an error refused to connect to http://server ip:8088.(As mentioned in the application guide to use only 8088 port)

Could you please elaborate in detail why should we use 8088 port in asterisk? and also what is the need of 5038 port that is mentioned in manger.conf file of asterisk.


#4

Port 8088 is the built-in HTTP server and in Asterisk 11 the only things available over it is SIP over Websockets, normal HTTP stuff, and some old Manager access stuff.

Port 5038 is for the supported Manager interface.

I can’t really elaborate why you’d use 8088, I have no idea what your application is or what it does.


#5

Thanks for the quick response. So from the given info, is it possible to access the asterisk server with port 8088 directly like http://server ip:8088 through browser?


#6

Define “access”. It runs an HTTP server. It can serve up files.


#7

Like we’re configuring asterisk with port 80 using freepbx in GUI mode. http://serverip:80
As like that is it possible to use port 8088 using freepbx and make config changes to asterisk


#8

FreePBX controls and configures the system, you can only make changes through the methods they provide. The Asterisk HTTP server is not one of those.


#9

Could you please have a look on screenshot and explain why acess it denied using 8088.


#10

FreePBX probably does not enable it as it would not be needed.


#11

How can i enable it? As i needed it in my application to integrate.


#12

I don’t use FreePBX and can’t comment on how to enable it within their world. You’d have better luck on their forums.


#13

Sure, thanks for the info.