The requested URL was not found on this server

Hello.

I have installed Asterisk on Ubuntu 8.10 with the apt-get command.
Then I have modified the manager.conf and http.conf.

http.conf

[general] enabled=yes enablestatic=yes bindaddr=0.0.0.0 bindport=8088

manager.conf

[general]
enabled = yes
webenabled = yes
port = 5038
bindaddr = 0.0.0.0

[administrator]
username = admin
secret = admin
read = system,call,log,verbose,command,agent,user,config
write = system,call,log,verbose,command,agent,user,config

ipaddress:8088 send back "The requested URL was not found on this server."
ipaddress:8088/asterisk/static/c … basic.html => Nothing to see here. Move along.
and ipadress:8088/static/ => Sorry, I cannot let you do that, Dave.

Wich server does Asterisk use ? Apache or something else ? Where can I change the root document or change some other settings ?

Thanks for helping me.

Asterisk uses Asterisk as its web server. I suspect you have another server conflicting for port 8088.

Hi.

It is a new installation of Ubuntu. No servers have been installed expect Asterisk.
When I stop it the port 8088 dosen’t send any response.

Thanks for reply :wink:.

Look in the directory /var/lib/asterisk/static-http, there are some html files, try open one of this, for example try open the index.html file through this url:

http://ipaddress:8088/asterisk/static/index.html

and check the result.

Cheerts.

Marco Bruni
www.marcobruni.net

I know this is old topic

the issue is the same what i am facing on my Asterisk-GUI 2.o

localhost:8088/asterisk/static/ajamdemo.html

I tried all the way i am getting the same error message

Hello,

Please check the following Asterisk CLI commands:

http show status[/code]

It will show us if the http server is enabled or not, the binding IP and the enabled URI, like the following output:
[code]tenora*CLI> http show status
HTTP Server Status:
Prefix: /asterisk
Server Enabled and Bound to 0.0.0.0:8088

Enabled URI's:
/asterisk/httpstatus => Asterisk HTTP General Status
/asterisk/static/... => Asterisk HTTP Static Delivery

In case you still have troubles - please double check your http.conf file.

HTH,
Ioan

it seems i am also the same error boat .

let me check once again and update

I tried all urls

its shows the same error for all the urls no change

tried

localhost:8088/asterisk/static/c … basic.html
localhost:8088/static/
localhost:8088/asterisk/static/index.html
localhost:8088/asterisk/rawman?action=status

[quote]Not Found

The requested URL was not found on this server.
Asterisk Server[/quote]

[code]
localhost*CLI> http show status
HTTP Server Status:
Prefix:
Server Enabled and Bound to 0.0.0.0:8088

Enabled URI’s:
/httpstatus => Asterisk HTTP General Status
/phoneprov/… => Asterisk HTTP Phone Provisioning Tool
/manager => HTML Manager Event Interface
/rawman => Raw HTTP Manager Event Interface
/static/… => Asterisk HTTP Static Delivery
/mxml => XML Manager Event Interface

Enabled Redirects:
None.
localhost*CLI> [/code]

well - why you put “asterisk” prefix there?

Did you noticed:

[quote]localhost*CLI> http show status
HTTP Server Status:
Prefix: [/quote]

I think you have to try the links you have mentioned without “asterisk”, like

localhost:8088/httpstatus

instead of

localhost:8088/asterisk/httpstatus

In order to check if “somebody” listen on 8088 please check this command and see if 8088 is displayed or not:

netstat -tlnp

PS: Because you have bind to 0.0.0.0 you could try also to connect to asterrisk_IP instead of localhost -> but probably you are testing from the same machine and this is why you are using “localhost” - right?

Thanks for the reply mate

Here is the out put i got on my Browser

[quote]
Asterisk™ HTTP Status
Prefix
Bind Address 0.0.0.0
Bind Port 8088
Asterisk and Digium are registered trademarks of Digium, Inc.[/quote]

netstat -tlnp

[quote]Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 2551/mysqld
tcp 0 0 0.0.0.0:5038 0.0.0.0:* LISTEN 2710/asterisk
tcp 0 0 0.0.0.0:2000 0.0.0.0:* LISTEN 2710/asterisk
tcp 0 0 0.0.0.0:8088 0.0.0.0:* LISTEN 2710/asterisk
tcp6 0 0 :::80 :::* LISTEN 2739/apache2
tcp6 0 0 :::22 :::* LISTEN 2683/sshd[/quote]

ok - so the asterisk internal web server is working and you are not on the localhost - thus you have to use the IP address of the Asterisk server (which I understand is 192.168.204.200) …now you have to play with it - but here I’m not a specialist.

you have to look to the following links (mentioned into Asteisk CLI by http show status):

[quote]Enabled URI’s:
/httpstatus => Asterisk HTTP General Status
/phoneprov/… => Asterisk HTTP Phone Provisioning Tool
/manager => HTML Manager Event Interface
/rawman => Raw HTTP Manager Event Interface
/static/… => Asterisk HTTP Static Delivery
/mxml => XML Manager Event Interface[/quote]

like:
192.168.204.200:8088/manager

HTH,
Ioan.

Hi Guys ,

Kindly try this Asterisk on Base OS i386 and patches with i686 .

you never face any issue .

Thanks
kartook