TFTP issue

I configured TFTP in one lan and my Asterisk server in other LAN. In between there are 3 routers but inter vlan routing is there. I am using SIP firmware for Cisco 7940. In DHCP scope Option 150 IP is the TFTP IP which is in other LAN as I mention. All required files for the phone to boot is available in TFTP boot. The phone is going to Unprovisioned mode. Even I entered the TFTP address manually through front panel but no luck.

If the TFTP is in the same LAN as of my Asterisk server everything works fine.Phone gets registered normally.

Can I configure TFTP and call processing server in two different LAN where reachability between the two lans are there ?


I dont think TFTP is a routable protocol. Im happy to here from anyone who has got it to work over a routed network , But I too have never got it to work.

You options are to put a tftp server on the local lan or use a different protocol for provisoning such as http or ftp. most phones also support these


TFTP is routable. The most likely problem is that the phone doesn’t have default router information at that stagein the bootstrap.


It possibly can survive non nat’d routing but not nat AFAIK, and I have never been able to get it to work via nat.

here is a description of the problem. and a possible solution.

[quote]TFTP uses UDP packets. The client connects from a random port to port 69, then the server connects back to the original port. This does not survive NAT (network address translation), possibly not on either end. trixbox pro and many other phone systems use TFTP for provisioning phones, so this is a problem for remote phones. Here is a fix that allows tftp traffic through an iptables based firewall (IPCop in this example).

You will need to enable ssh on the firewall and connect a session. IPCop uses non-standard port 222, and can usually only be connected to from the internal (green) network.

nano /etc/rc.d/

add these two lines:
modprobe ip_conntrack_tftp
modprobe ip_nat_tftp

Save and exit.

For immediate effect, repeat the two lines at the command prompt, or reboot the firewall. I had to repeat this on both firewalls, as IPCop firewalls were on both ends.

If using trixbox pro, you also need to make a few minor changes to the configuration files for the phones in order for the phone to try the correct server. Change the settings to where NNNN is your server number. I modified the file itself. Fonality recommends modifying the phone config on the phone once it is initially configured.