TE411p in HP Proliant DL140 G2 crashes

We have a lot of problems with te411p card and DL140 hp server. If anyone has success with this configuration please post here.
Our DL140 server has two Intel Xeon 2.8 mhz processors.
I’ve installed Trixbox, so I have CentOS 4.3 and asterisk ver., zaptel 1.2.6, libpri 1.2.3
First problem is interrupts. Digium card and network adapter always get the same interrupt - 169. I’ve tried to disable both onboard ethernet controllers and use standalone pci ethernet card but I always get this:

cat /proc/interrupts CPU0 CPU1 CPU2 CPU3 0: 433 10004 7050757 7099545 IO-APIC-edge timer 1: 0 0 1773 1579 IO-APIC-edge i8042 8: 0 0 0 1 IO-APIC-edge rtc 9: 0 0 0 0 IO-APIC-level acpi 12: 0 0 0 66 IO-APIC-edge i8042 14: 1 24 0 19 IO-APIC-edge ide0 15: 0 0 27222 29727 IO-APIC-edge libata 169: 15617038 0 0 11068 IO-APIC-level eth0, wct2xxp NMI: 0 0 0 0 LOC: 14160920 14160919 14160918 14160917 ERR: 0 MIS: 0
wct2xxp is te211p card which is used now instead of te411p but the situation with te411p is same.
The main problem is that asterisk box with te411p card in it always crashes. When several simultanious calls (7-8) are made we get this message.

l 5 08:46:31 asterisk1 kernel: Uhhuh. NMI received for unknown reason 31 on CPU 0. Jul 5 08:46:31 asterisk1 kernel: Dazed and confused, but trying to continue Jul 5 08:46:31 asterisk1 kernel: Do you have a strange power saving mode enabled
After that card is unavailable and outgoing calls can’t be made.

Don’t know what to do and how to be :frowning:. te211p is working fine now, we use it during work hours. In the evening we will try to do something with te411p because we have to make it work in the nearest feature…
If anyone could help please help.

well, we had a similar issue with our Dell PE2850’s w/TE410P’s - they would randomly lock up, sometimes under a slight load, sometimes under no load at all. i would also see the NMI error, but when the system would lock, it would be a hard lock, and nothing would be dumped to any of the logs.

our fix? move to sangoma hardware. since we moved to sangoma, not a single lock up. when we DID move back to a digium card for one of our servers (for DTMF reasons that were actually the fault of the telco), the system started locking up again.

that may not be the fix for you, but it worked like a charm for us.

whoiswes, thanks for the answer.

We have tried to do some kind of crash test for our HP with te410p. We 've connected 1 port with 3 port and 2 with 4. I’ve made simple dialplan and generated 30 calls via 3rd port to 1st where asterisk answers and dials Zap/g2 (2nd port). So all lines have been busy… No crash. So the problem is that we cannot reproduce the crash. If we watch the logs we see that * crashes in the morning when only 3-4 simultanious calls are being made.
We’ve tried to disable HT. This doesn’t help.
Digium doesn’t recommend to use
I think we will buy a new server :frowning:.