TE120P card to configure

Iam having card TE120P & want to configure it. I have configure as per the settings of the manual .But still its not working (card showing red light)
The steps that i followed are

  1. etc/zaptel

  2. etc/asterisk/zapata

    ; define any trunk groups

; hardware channels
; default

E1 Channel Bank


  1. extension.conf
    exten => 1200,1,Answer()
    exten => 1200,n,Echo()

  2. modprobe wcte12xp

5./sbin/ztcfg -vv

  1. zttool (where card is showing RED)

Please tell me where iam wrong

when i gave this restart command I got this error
/etc/init.d/zaptel restart

Unloading zaptel hardware drivers:ERROR: Module zaptel is in use . Loading zaptel framework: [ OK ] Waiting for zap to come online...OK Loading zaptel hardware modules: tor2. wct4xxp. wct1xxp. wcte11xp. wctdm24xxp. wcfxo. wctdm. wcusb. xpp_usb. No functioning zap hardware found in /proc/zaptel, loading ztdummy Running ztcfg: ZT_SPANCONFIG failed on span 1: Invalid argument (22) [FAILED]

I am assuming your channel bank is all FXS ports (for ceonnections to analog phones) correct? If so you config looks okay so go to the next step. If you have FXO ports in the channel bank (for connecting to PSTN) your signalling is backwards (i.e use fxsks in zaptel.conf and fxs_ks in zapata.conf).

Have you tried putting in a loopback plug into the card? You can do a google search to find the pin assignments for a loopback plug if you dont have one. When you plug in the loopback plug the card should go green, if it does then your cable is bad or your channel bank is not set correctly. If the card doesn’t go green I would suggest calling digium support, it’s free with the purchase of the card. Also you need make sure the zaptel module shuts down after you plug in the loopback so you can restart it. The easiest way is to just reboot the server but there are ways of forcing it to shutdown without restarting the server.

Ya the channel bank is FXS port
I have loopback the cable .It goes to green .
Does it means that the context=channel bank is not set correctly . Kindly can u elaborate more

Hi What version of zaptel are you using ?

also have you got the jumper correcrt ?


iam using zaptel 1-4.10 ,ya i think jumpers are set correctly its in a E1 mode .Any other information let me know

since the card goes green with the loopbak the card should be okay.

Have you tried a different cable between the card and channel bank?

I suspect the config on the channel bank is not correct. What channel bank are you using?