SPA-941, Call Park and *


#1

I’m relatively new to Asterisk, however not to IP phone systems (worked with both Cisco and 3Com). Working on a pilot program and to get jumpstarted have just loaded A@H. I’ve spent the past coupl eof hours perusing the forums.

I seem to be able to do just about everything I want to do with 3 exceptions:

  1. Parking a call will work but does not tell me where the darn thing got parked. Not a big deal with the small 6 phone pilot but may just be a big prob with the planned 300 phone rollout. Is this an asterisk config or SPA-941 config/function problem?

  2. Hitting # for a name directory in the auto attendant. It asks for a name, I put it in, it finds it, I press 1 to select the name - and I get hung up on.

Thanks for any suggestions you may have…

  1. Using the SPA-941 phones I can’t seem to use the * key to do things like record the main greeting, listen to weather, or any of that other fun stuff. This is def a phone “feature” because it works with the X-Lite softphone. Just hoping someone has a suggestion on how to get around this.

#2
  1. check the permissions on the /var/lib/asterisk/sounds/digits directory. post from me yesterday with an appropriate fix.

  2. possibly the same problem, if you have the option set to play the extension number to you before transfer.

  3. sounds like vertical service codes interfering with the A@H features. can you remove them ? or is it another phone that won’t timeout-dial if the number starts with an *


#3

The guy yesterday was right…you are the man!

Clearing out all of the vertical service activation codes (which I don’t suspect I need while using this phone with Asterisk) did the trick. So did the permissions thing for the other two questions.

Thanks bro!