[solved] How to force asterisk to play a .wav file?

It wants mono and 8k, then works

Interesting new forums, the old ones worked though.

Launching Playback(/home/testing/input/msg1.wav) on Local/1@profile1-0000000e;1
[Feb  4 19:27:48] WARNING[15550]: file.c:666 ast_openstream_full: File /home/testing/input/msg1.wav does not exist in any format
[Feb  4 19:27:48] WARNING[15550]: file.c:957 ast_streamfile: Unable to open /home/testing/input/msg1.wav (format 0x40 (slin)): No such file or directory
[Feb  4 19:27:48] WARNING[15550]: app_playback.c:479 playback_exec: ast_streamfile failed on Local/1@profile1-0000000e;1 for /home/testing/input/msg1.wav

Hm, how to have it find the file?

Please specify a category for the forum.(Asterisk Support).

You must not include the extension on the sound file name, in the Playback application, only on the file itself. Asterisk will choose the format that it least costly to convert to that used by the channel.

Also note that Asterisk cannot cope with general .wav files. .wav, in lower case, is 8kHz, mono, 16 bit, signed linear. (.WAV is RIFF wrapped GSM.)

Great additional info regarding the not placing the file extension in the playback statement.