[SOLVED] Digium d50 loop rebooting issue

Can someone, please, suggest me something with my issue?
I’m using Digium d50 ip phone with asterisk.
The problem i have is:
I tried to configure my d50 from configuration file, so i reset my d50 to factory defaults and on boot configured option “Fetch configuration file from url” (using http) and after this my phone started to rebooting in the loop after downloading file.
Also when i go to settings menu before it starts to reboot and opened web gui at this moment, i saw that configuration from config file is there, but i don’t understand why my phone is still rebooting after fetching the file?

Configuration via web gui works fine, but it’s way too long to configure my phone like this.


Likely some element of the configuration file being loaded is causing trouble for the phone. Try starting with a more basic configuration file and see if you can figure out what element is problematic.

The phone’s web UI should not generally be used as a config method in conjunction with the XML configuration methods. They should be used exclusively.

Thank you for this idea!
I figured out that there is an error in network and firmware sections, so i deleted them and all works now!
If someone has the same problem, do not forget to reset to factory defaults before changing configuration file, cause i’ts not works without it (at least for me).