Digium D70 Bootloop

I have a fresh install of an asterisk server. The Digium D70 is able to contact the server and pull the config. It then finishes loading all appears fine but before you can do anything it immediately reboots and does the same thing all over again. Pulling config loading and then rebooting. Over and over.

I haven’t used asterisk in years and the last time I did this it worked fine.

I have disabled all firewalls for testing purposes. I have resintalled the asterisk server twice. I have reset phone to factory defaults multiple times. I have tried adding additional extensions to connect phone to.

Nothing changes always the same boot looping.

Any thoughts?

You can see it connects then drops almost immediately in the statistics window.image


With the given information, it’s hard to say why it’s decided to restart itself. It could be getting different configuration directives that cause it to do a self-restart, but that would usually occur earlier in the process - before it comes up and shows the phone UI screen. It’s more likely that it’s been given a bad configuration of some type that it’s unable to process. The two ways to approach that are to turn on the remote syslogging and push that somewhere you can read, or to start with a very basic configuration and start adding things until you figure out what’s causing the sadness.

Yeah I litreally added an extension. That is all. Gave the necessary info like extension id and such. I have been trying to find how to open the syslog not through freepbx webpage and have been unable too. The wiki is mostly blank to me. Not sure what the issue is. I appareciate your help.

The conf is super simple as far as I can tell. I haven’t added any trunks or anything to asterisk yet. Just literally the basic extension.

If you could be so kind as to link like a readme document or a wbepage that shows how to use commands from terminal would appreciate.

It’s been looping now for an hour. I gotta think it’s config but I don’t know how to make it any simpler.

Could old firmware be the issue? I tried to update to something more current but I can’t via the phones web interface and not sure of how to from freepbx web gui.

Sorry for terrible lack of knowlege and I swear I have tried googling and searching and apparently I am not any better at doing that then setting up asterisk. :facepalm:


The phone doesn’t output the syslog by default. There’s nothing in FreePBX UI that’s a syslog viewer, and I don’t know if the syslog server installed with FreePBX allows remote writes. The wiki (https://wiki.asterisk.org/wiki/display/DIGIUM/Sangoma+D-Series+Phones) isn’t blank for me.

If it’s looping, something’s making it sad, and it’s not going to become un-sad, given the same sad configuration, just with an application of time.

w.r.t. firmware, there was an issue running DPMA >=2.x against firmware <= 2.0, so you could check the DPMA version and the firmware version.

after much trial and error i finally got the phone to update firmware. Will see what happens with updated firmware it was on 1_3_2 or something quite old.

Thanks for youyr help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.