Slow extension dialling


Sorry in advance if anything is missing.

I am running Asterisk 1.2 under Linux and at the moment have one extension in extensions.conf and several SIP peers connected OK. If I dial the one extension I have setup

exten => 333001,1,Dial(SIP/333001)

It take about 7 or 8 seconds to recognise that I only wanted to dial 333001 before calling SIP/333001 - I am pretty sure that it used to dial almost instantly, but then I changed something (I think in zapata.conf or voicemail.conf) and it now seems to get the number I am dialling, timeout when I enter no more digits then dial the number.

Any ideas why? If I dial 333001# it dials instantly. This was a fully working prepaid PBX system but I have stripped it right back to solve this problem.



Bump! Anyone got any ideas? I am sure this is a newbie question?


it sounds more like the phone you are using has a digit timeout set too high for your liking. if you look at the console while dialling, is the holdup in Asterisk, or the time it takes for the phone to start dialling ?

what phone is it ?


I am using a Linksys PAP2 ATA with a “normal” cheap telephone plugged in - nothing starts to move on the asterisk console until the digit timeout is reached, or until I dial the # key.

Just for testing there is only one extension now setup and that is 333001.

I was under the impression that asterisk was fairly intelligent and wouldn’t sit around waiting for digits if what has been dialled uniquely matches an extension… is this correct?


not use about the early-dial capabilities of Asterisk. but the problem is with your PAP2 dialplan. Asterisk can’t dial until the PAP2 sends the number, so you either use the termination character (#), have a digit timeout that suits, or have a dialplan that sends the number as soon as it has a match.

what dialplan do you have on the PAP2 ? and where are you, what numberplan does your telco use etc etc.

this is mine … simple but it works for me code[/code]

and i have a 2 second timeout for interdigit.


OK thanks for that… I hate it when I read this normally but…

I am loathed to start touching the PAP2 because the system used to be alot more responsive and the only thing I have touched is Asterisk. Something asterisk side has affected how long it takes to recognise dialled numbers and extensions.

Anyone any ideas what in asterisk could affect the digit timeout?


I have to say, its your PAP2, because I had the same problem until I changed it on my PAP2. I understand the “dont fix it if it aint broke” but, its the PAP2

Fair enough, putting this in as the dial plan


has solved the problem… well I say solved… it has made the dialing instant which it never has been rather than 2 - 3 seconds which it was before it started being 7 or 8 seconds.

It works so I am happy. Ho hum c’est la vie!

Thanks guys, all help is appriciated!