Asterisk and Linksys PAP2T extension not found

Disclaimer: I’m completely new to Linux Ubuntu, Asterisk, and pretty much all things computers :slight_smile: Thanks in advance for explaining it like I am 5!

I am doing a simple art project connecting two analog phones via a PAPT2. I set the extensions up as softphones first to test and they can each dial the other (yay!). I plugged them into a PAPT2 and configured the IP and the phones both get dial tones (double yay!). The problem I am having is that when I go to dial one analog phone to another, it times out after the first digit and says extension ‘2’ rejected because extension not found in context ‘internal’. The full extension is 2020.

Why would this work between the two softphones but not between the two analog phones?

What more information should I share for someone to be able to help? And is there any information I should not share on here from my sip.conf and extensions.conf files?

Thanks so much in advance!

Another point to add is that I bought the PAP2T secondhand and it was not reset to factory settings, so I’m wondering if it is something in those settings that is the issue. Under Regional settings, the Interdigit Long Timer is 10 and Interdigit Short Timer is 3, but it is timing out much before that.

You need to set the dialplan on the ATA, so that it knows when the number is complete and doesn’t start the call too early. The name for this varies between brands.

Analogue phones always send digits individually, so the exchange has to deal with determining whether a number is complete, but more sophisticated systems, like mobile phones and VoIP send the complete number, all at once, when they think dialling is complete.

Excellent, thank you David! :eyes: looking into dial plans now

OK that worked! I made it super simple (20xx|19xx). Thank you again, David!

If I have more questions about different issues, is it best to open new threads?

For example now one analog phone can call the other, 2022 to 2020, and it rings, but the other way from 2020 to 2022 doesn’t ring, it jumps to the next step on the extension plan, which is Playback(vm-nobodyavail). However when I enable the softphone 2022, the analog phone 2020 can call through to the softphone 2022. Any idea why that would be?

TIA

Apart from looking for asymmetries in the configuration, you need to enable the full log in logger.conf, and set core verbosity to 5, to see why the call is failing. You may need to issue “pjsip set logger on” on the CLI for more detail, assuming you are using the current SIP driver.

OK, thanks!