Sip reload no such command

I’m following the wiki page
And I’ve got to the part where I need to “sip reload”.
However, I’m getting an error instead: ‘sip reload’ no such command

I’m running asterisk 11.0.1 compiled from sources on a VM with Fedora17.

I’ve tried: module load as I’ve seen on related questions online but this does not work. I’m seeing two warnings from loader.c that the module ‘chan_sip’ could not be found at /usr/lib/asterisk/modules/
I’ve checked the directory and indeed there is no there.

has this command been replaced maybe and the wiki is just not up to date yet?
or perhaps I’ve missed something else?

You will have failed a pre-requisite for building SIP support. Probably a missing encryption library.

“make menuconfig” should confirm that it isn’t being built and tell you which dependency is missing.

I’ve found that the unmet dependency is res_crypto.
It also has one unmet dependency and it is openssl(E).

however I can’t find it on the menu, and if it requires the linux package, it was already installed.

how do I move on from here?

sudo yum install openssl-devel

you’ll probably need to run make clean from the asterisk source directory then rerun ./configure and make menuselect to verify that chan_sip will be available.

The sip reload command now seems to work.

I have another problem now.

I’ve followed the instructions on the page I listed above and I tried to register a sip client using ekiga. I’m getting an error: “could not register (Transport error)”

I probably did something not quite right.

The asterisk is running on a VM and it’s IP address is
I can ping to this address from other computers in the network including the host OS.
while trying to connect I’m watching over asterisk with verbose mode 3 and nothing appears.

what could be the problem?

Please post the portion of your sip.conf file containing the peer configuration for the ekiga softphone and please post links to screenshots of your ekiga settings.

I’d have checked what transport are both Asterisk and SIP client are using (TCP or UDP)

I’ve added the code in the wiki in it’s exact form except for network setting (might that be the problem? ) the the end of the sip.conf.sample file and created a copy of the result named sip.conf


and here are my ekiga settings:

is there any way to verify that asterisk read the sip.conf file as expected?

I would add username=demo-alice to the [demo-alice] section. At the cli:

shows you a list of peer entries.

If your sip.conf is being parsed correctly, you should see something like the following:

Name/username              Host            Dyn Forcerport ACL Port     Status
demo-alice/demo-alice 192.168.1.x      D         N         A   5060     OK (16 ms)

The last column would only show OK if the phone is registered.

Are you running the VM on a windows host? If so, you need to make sure that windows firewall allows ekiga network access. I would temporarily turn it off for testing purposes.

Well, turns out I edited the wrond sip.conf file.
I found that asterisk read the file from /etc/asterisk/sip.conf

edited this and now when I use ‘sip show peers’ I see what I expect.

HOWEVER! Still does not work. Ekiga fails with the message “remote party host is offline”

I’ve checked ping to the machine and it answers.
I am running the vbox from an Ubuntu host and I’m pretty sure I don’t have a firewall here (I just upgraded to 12.04, maybe they went crazy and added a firewall to this version?).

Also, I’ve noticed in line 210 in sip.conf there is a line that says:

in the comments to this line it says it the default, but I suspect it has something to do with my problem?

what else do you think could go wrong?

That should not be your problem. sip is usually run over UDP. What I would imagine is the problem is that you are running ekiga on the same machine as the VM and both asterisk and ekiga are trying to use port 5060. You could try setting port=5061 under [general] in sip.conf and then sip reload in the cli.


The VM itself had a firewall.
ran the command:

fixed it.

I thought I would have to reinstall. This simple command got sip working again. thanks “module load”