Module Missing?

Hello all,

I’ve installed Asterisk version 17.4.0 on an Ubuntu virtual machine on my Windows laptop.

When I tried running the sip show peers command, I receive the error “No such command ‘sip show peers’ (type ‘core show help sip show’ for other possible commands)”

After researching on the forums about this error, I discovered that it generally stems from an issue with the file. And so I ran the command “module show like chan_sip.”
This returned with 0 modules found or loaded.

The next area I checked was the menu, by running make menuselect in the terminal. The chan_sip file was selected.

Upon realizing this I searched in the files out of curiosity, and found the file in usr/src/asterisk-17.4.0/channels.

Why isn’t Asterisk able to find and use this module? What else can I try to resolve this issue?

Thanks for any advice!

chan_sip is being deprecated, in favour of chan_pjsip. As such, you must compile from source and explicitly enable it during “make menuselect”.

It only has community support, so bugs may not be fixed, or not fixed quickly.

@david551 chan_pjsip is enabled for me. Is there more I have to do to switch over?

Try to load " module load" on cli and now you can see that when you do sip show peers its now available

@Taurai Thank you so much! You’re correct, that solved the issue. Can’t believe I missed something so simple. :stuck_out_tongue:

Just to make sure it stays ‘fixed,’ remember to add it to your modules.conf.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.