[resolved] wctdm24xxp0: Fatal Bus Error detected!

Hello all,

After installing Zaptel I get this in syslog:

kernel: wctdm24xxp0: Fatal Bus Error detected!

This message is repeated about 61000 times a minute.

It does this on openSUSE 11.1, CentOS 5.3 and Ubuntu 8.10

I have tried installing many, many times, trying different versions and still no luck

zaptel comes up fine and there are no errors loading the modules.

I currently have asterisk installed on CentOS 5.3 with 4 channels configured:

[code]ztcfg -vv
Zaptel Configuration

Channel map:

Channel 01: FXS Kewlstart (Default) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Slaves: 04)

4 channels configured.[/code]

I am able to call into asterisk and get the “congratulations, you have successfully installed asterisk. . .” message. But still getting the kernel error

here are the interrupts:

cat /proc/interrups CPU0 CPU1 0: 22836 262022 IO-APIC-edge timer 1: 0 3 IO-APIC-edge i8042 8: 0 1 IO-APIC-edge rtc 9: 0 0 IO-APIC-level acpi 12: 0 5 IO-APIC-edge i8042 14: 1084 1021 IO-APIC-edge ide0 50: 611 714 IO-APIC-level ohci_hcd:usb2 58: 13704 16307 IO-APIC-level sata_nv, HDA Intel 66: 0 0 IO-APIC-level sata_nv 74: 982 511383 IO-APIC-level wctdm24xxp0 82: 1336 22091 PCI-MSI eth0 233: 0 3 IO-APIC-level ehci_hcd:usb1 NMI: 0 0 LOC: 284614 284613 ERR: 1 MIS: 0

I have no idea what’s wrong. Any ideas?

Thank you.

Please contact Digium technical support.
+1 256 428 6000

I had that error before and moved it to an new pci slot and it all worked fine.

Ok, I’ll try moving it to a different slot. If that doesn’t work I’ll call Digium support. Thanks guys!

What server are you using ?


I have Asterisk and Zaptel 1.2 (installed using BRIstuff) running on a Sun Ultra20M2. I wasn’t able to get Asterisk and zaptel 1.4 working, but hopefully will once this problem is resolved.

Not 100% sure how compatible zaptel is with the sun hardware.

Have a google for Asterisk on Sun hardware and see what it brings up.

I think Asterisk is OK its zaptel thats the issue.


OK, I’ll see what I can find. Thanks for the tip!

Moving the card to a new PCI slot worked. Thank you!